CVE-2009-0755
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to...
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
Exploit likelihood
What each source reports
NVD Score used
5.0
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
- Record
CVE-2009-0755- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
- Record
CVE-2009-0755- Updated
- 2026-11-02
EUVDEUVD-2009-0755 No score
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
- Record
EUVD-2009-0755- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jmc7-m54g-vwh9 No score
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to...
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
- Record
GHSA-jmc7-m54g-vwh9- Updated
- 2026-11-02
OSV No score
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
- Record
CVE-2009-0755- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-0755 No score
The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
- Record
DEBIAN-CVE-2009-0755- Updated
- 2026-11-02
Affected products
Affected packages
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Poppler 0.10.3 - Denial of Service | 2009-02-12 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-0755 is a medium vulnerability (CVSS 5.0) in Poppler, published March 3, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 10.8%, the 95th percentile. Fixed in poppler 0.10.6-1.
References
securityfocus.com/bid/33749
debian.org/security/2009/dsa-1941
lists.freedesktop.org/archives/poppler/2009-January/004406.html
secunia.com/advisories/33853
openwall.com/lists/oss-security/2009/02/19/2
secunia.com/advisories/37114
Show 10 moreShow less
openwall.com/lists/oss-security/2009/02/13/1
wiki.rpath.com/Advisories:rPSA-2009-0059
bugs.freedesktop.org/show_bug.cgi?id=19790
secunia.com/advisories/35685
ubuntu.com/usn/USN-850-1
securityfocus.com/archive/1/502761/100/0/threaded
lists.opensuse.org/opensuse-security-announce/2009-07/msg00002.html
nvd.nist.gov/vuln/detail/CVE-2009-0755
github.com/advisories/GHSA-jmc7-m54g-vwh9
security-tracker.debian.org/tracker/CVE-2009-0755