Every CVE Search/ Get API key

CVE-2017-18121

SimpleSAMLphp XSS Vulnerability

6.1 MediumFix available

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.19%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
CVE-2017-18121
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
CVE-2017-18121
Updated
2026-11-02
EUVDEUVD-2022-3835 No score

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
EUVD-2022-3835
Updated
2026-11-03
GitHub AdvisoriesGHSA-fv7m-wc3v-wr3w 6.1

SimpleSAMLphp XSS Vulnerability

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
GHSA-fv7m-wc3v-wr3w
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
CVE-2017-18121
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-18121 6.1

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
DEBIAN-CVE-2017-18121
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-fv7m-wc3v-wr3w 6.1

SimpleSAMLphp XSS Vulnerability

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
GHSA-fv7m-wc3v-wr3w
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2017-18121 6.1

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Record
UBUNTU-CVE-2017-18121
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
simplesamlphp/simplesamlphp
Packagist
1.12.0 up to 1.14.16
1.14.16
simplesamlphp
Debian:12
before 1.15.0-1
1.15.0-1
simplesamlphp
Debian:14
before 1.15.0-1, plus listed versions
1.10.0-11.11.0-11.12.0-11.12.0~rc1-11.12.0~rc2-1
Show 34 moreShow less
1.13.0-11.13.1-11.13.1-21.13.2-11.14.0-11.14.1-11.14.10-11.14.11-11.14.15-11.14.2-11.14.2-21.14.3-11.14.4-11.14.5-11.14.6-11.14.7-11.14.8-11.14.9-11.6.0-11.6.1-11.6.2-11.6.3-11.6.3-21.6.3-31.7.0-11.7.0-21.8.0-11.8.1-11.8.2-11.9.0-11.9.0~rc1-11.9.0~rc2-11.9.1-11.9.2-1
1.15.0-1
simplesamlphp
Debian:7
From an advisory covering 3 CVEs
before 1.9.2-1+deb7u2, plus listed versions
1.9.2-11.9.2-1+deb7u1
1.9.2-1+deb7u2
simplesamlphp
Debian:8
From an advisory covering 9 CVEs
before 1.13.1-2+deb8u1, plus listed versions
1.13.1-2
1.13.1-2+deb8u1
simplesamlphp
Debian:9
From an advisory covering 9 CVEs
before 1.14.11-1+deb9u1, plus listed versions
1.14.11-1
1.14.11-1+deb9u1
simplesamlphp/simplesamlphp
Packagist
1.12.0 up to 1.14.16, plus listed versions
v1.12.0v1.13.0v1.13.0-rc1v1.13.0-rc2v1.13.1
Show 18 moreShow less
v1.13.2v1.14.0v1.14.0-rc1v1.14.1v1.14.10v1.14.11v1.14.12v1.14.13v1.14.14v1.14.15v1.14.2v1.14.3v1.14.4v1.14.5v1.14.6v1.14.7v1.14.8v1.14.9
1.14.16
simplesamlphp
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.13.2-11.14.0-11.14.0-1ubuntu21.14.0-1ubuntu2+esm1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-18121 is a medium vulnerability (CVSS 6.1) in Simplesamlphp, published February 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 68th percentile. Fixed in simplesamlphp/simplesamlphp 1.14.16.

References

Show 4 moreShow less
MoveEnter Open