Every CVE Search/ Get API key

CVE-2026-108097

Drupal core - Critical - Remote code execution - SA-CORE-2026-014

8.1 HighPublic exploitFix available

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.57%Up 0.2 points since Oct 30, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.1

Drupal core - Critical - Remote code execution - SA-CORE-2026-014

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Record
CVE-2026-108097
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-470
Updated
2026-11-06
EUVDEUVD-2026-113557 8.1

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Record
EUVD-2026-113557
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-06
GitHub AdvisoriesGHSA-x75q-mvwp-2h36 8.1

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability...

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Record
GHSA-x75q-mvwp-2h36
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-470
Updated
2026-11-06
NVD 8.1

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Record
CVE-2026-108097
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-470
Updated
2026-11-06
OSV 8.1

Drupal core - Critical - Remote code execution - SA-CORE-2026-014

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Record
CVE-2026-108097
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-470
Updated
2026-11-07
OSVCLSA-2026-1792527484 No score

TuxCare security update for drupal/core (3 CVEs)

TuxCare rebuilt drupal/core to address 3 CVEs. Fixed in 10.6.17-p1+tuxcare.

Record
CLSA-2026-1792527484
Updated
2026-11-02
Show 5 moreShow less
OSVCLSA-2026-1792527640 No score

TuxCare security update for drupal/core (3 CVEs)

TuxCare rebuilt drupal/core to address 3 CVEs. Fixed in 10.5.12-p2+tuxcare.

Record
CLSA-2026-1792527640
Updated
2026-11-02
OSVCLSA-2026-1792529137 No score

TuxCare security update for drupal/core (2 CVEs)

TuxCare rebuilt drupal/core to address 2 CVEs. Fixed in 8.9.20-p8+tuxcare.

Record
CLSA-2026-1792529137
Updated
2026-11-02
OSVCLSA-2026-1793031776 No score

TuxCare security update for drupal/core (1 CVE)

TuxCare rebuilt drupal/core to address 1 CVE. Fixed in 9.5.11-p7+tuxcare.

Record
CLSA-2026-1793031776
Updated
2026-11-02
OSVDRUPAL-CORE-2026-014 No score

A remote code execution vulnerability exists within the Field UI module in Drupal core.

The vulnerability is not directly exploitable with core alone, but multiple serious exploit paths exist with contributed modules. At least one known exploit path does not require authentication. Custom code may also expose the vulnerable functionality.

The vulnerability can be mitigated by uninstalling the core Field UI module (field_ui), which will provide protection while sites are updated.

Drupal Steward protection:

This issue is being protected by Drupal Steward. Sites that use Drupal Steward are already protected from some known attack vectors, but the protection offered will not cover all possible exploits. Sites should upgrade in the near future in case additional attack vectors are discovered.

Record
DRUPAL-CORE-2026-014
Updated
2026-11-02
OSVROOT-APP-COMPOSER-CVE-2026-108097 No score

CVE-2026-108097 in drupal/core - Patched by Root

Root has patched CVE-2026-108097 in the drupal/core package for Root:Composer. Multiple fixed versions available.

Record
ROOT-APP-COMPOSER-CVE-2026-108097
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/core
TuxCare:Packagist
From an advisory covering 3 CVEs
10.6.17 up to 10.6.17-p1+tuxcare
10.6.17-p1+tuxcare
drupal/core
TuxCare:Packagist
From an advisory covering 3 CVEs
10.5.12 up to 10.5.12-p2+tuxcare, plus listed versions
10.5.12-p1+tuxcare
10.5.12-p2+tuxcare
drupal/core
TuxCare:Packagist
From an advisory covering 2 CVEs
8.9.20 up to 8.9.20-p8+tuxcare, plus listed versions
8.9.20-p1+tuxcare8.9.20-p2+tuxcare8.9.20-p3+tuxcare8.9.20-p4+tuxcare8.9.20-p5+tuxcare8.9.20-p6+tuxcare8.9.20-p7+tuxcare
8.9.20-p8+tuxcare
drupal/core
TuxCare:Packagist
9.5.11 up to 9.5.11-p7+tuxcare, plus listed versions
9.5.11-p1+tuxcare9.5.11-p2+tuxcare9.5.11-p3+tuxcare9.5.11-p4+tuxcare9.5.11-p5+tuxcare9.5.11-p6+tuxcare
9.5.11-p7+tuxcare
drupal/core
Packagist
8.9.0 up to 10.6.19, 11.0.0 up to 11.3.19, 11.4.0 up to 11.4.10, 12.0.0-alpha1 up to 12.0.0-beta2, plus listed versions
10.0.010.0.0-alpha110.0.0-alpha210.0.0-alpha310.0.0-alpha4
Show 45 moreShow less
10.0.0-alpha510.0.0-alpha610.0.0-alpha710.0.0-beta110.0.0-beta210.0.0-rc110.0.0-rc210.0.0-rc310.0.110.0.1010.0.1110.0.210.0.310.0.410.0.510.0.610.0.710.0.810.0.910.1.010.1.0-alpha110.1.0-beta110.1.0-rc110.1.110.1.210.1.310.1.410.1.510.1.610.1.710.1.810.2.010.2.0-alpha110.2.0-beta110.2.0-rc110.2.110.2.1010.2.1110.2.1210.2.210.2.310.2.410.2.510.2.610.2.7
10.6.1911.3.1911.4.1012.0.0-beta2
drupal/core
Root:Composer
before 9.8.0-p12007001+root.io
9.8.0-p12007001+root.io

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubFurkanKAYAPINAR/CVE-2026-1080972026-10-15
PoC in GitHubfortbridge/cve-2026-108097-research2026-10-18
PoC in GitHubExDev994/CVE-2026-1080972026-10-20

History

History
RecordedChangedSources
severityCVE List
severityEUVD
affected, exploits, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-108097 is a high vulnerability (CVSS 8.1) in Drupal Core, published October 14, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in drupal/core 9.5.11-p7+tuxcare.

References

This page doesn't list everything

Left out here: 298 versions. The JSON record has them.

MoveEnter Open