MGASA-2013-0164
Updated flightgear package fixes security vulnerability
It was reported that FlightGear suffers from improper handling of format strings when FlightGear is started with allowances for remote access (via the --props or --telnet commandline arguments). If a remote attacker were able to connect to FlightGear and set special parameters related with clouds, it could cause FlightGear to crash.
What each source reports
OSV No score
Updated flightgear package fixes security vulnerability
It was reported that FlightGear suffers from improper handling of format strings when FlightGear is started with allowances for remote access (via the --props or --telnet commandline arguments). If a remote attacker were able to connect to FlightGear and set special parameters related with clouds, it could cause FlightGear to crash.
- Record
MGASA-2013-0164- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
flightgearMageia:2 |
before 2.6.0-2.3.mga2 | 2.6.0-2.3.mga2 |
flightgearMageia:3 |
before 2.10.0-1.3.mga3 | 2.10.0-1.3.mga3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
MGASA-2013-0164 is a vulnerability with no CVSS score yet in flightgear, published June 6, 2013. No source lists public exploit code. Fixed in flightgear 2.6.0-2.3.mga2.