MGASA-2014-0323
Updated apache-mod_wsgi package fixes security vulnerability
apache-mod_wsgi before 4.2.4 contained an off-by-one error in applying a limit to the number of supplementary groups allowed for a daemon process group. The result could be that if more groups than the operating system allowed were specified to the option supplementary-groups, then memory corruption or a process crash could occur.
What each source reports
OSV No score
Updated apache-mod_wsgi package fixes security vulnerability
apache-mod_wsgi before 4.2.4 contained an off-by-one error in applying a limit to the number of supplementary groups allowed for a daemon process group. The result could be that if more groups than the operating system allowed were specified to the option supplementary-groups, then memory corruption or a process crash could occur.
- Record
MGASA-2014-0323- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apache-mod_wsgiMageia:3 |
before 3.5-1.mga3 | 3.5-1.mga3 |
apache-mod_wsgiMageia:4 |
before 3.5-1.1.mga4 | 3.5-1.1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
MGASA-2014-0323 is a vulnerability with no CVSS score yet in apache-mod_wsgi, published August 8, 2014. No source lists public exploit code. Fixed in apache-mod_wsgi 3.5-1.mga3.