MGASA-2015-0454
Updated uglify-js packages fix security vulnerability
The UglifyJS node module has a problem where the combination of De Morgan's Law and non-boolean values can lead to a case where code is incorrectly minified, which can lead to possibly malicious minified JS code.
What each source reports
OSV No score
Updated uglify-js packages fix security vulnerability
The UglifyJS node module has a problem where the combination of De Morgan's Law and non-boolean values can lead to a case where code is incorrectly minified, which can lead to possibly malicious minified JS code.
- Record
MGASA-2015-0454- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
uglify-jsMageia:5 |
before 2.4.24-3.mga5 | 2.4.24-3.mga5 |
nodejs-align-textMageia:5 |
before 0.1.3-1.mga5 | 0.1.3-1.mga5 |
nodejs-ansi-regexMageia:5 |
before 2.0.0-1.mga5 | 2.0.0-1.mga5 |
nodejs-camelcaseMageia:5 |
before 1.2.1-1.mga5 | 1.2.1-1.mga5 |
nodejs-center-alignMageia:5 |
before 0.1.1-1.mga5 | 0.1.1-1.mga5 |
nodejs-cliuiMageia:5 |
before 3.0.3-1.mga5 | 3.0.3-1.mga5 |
nodejs-code-point-atMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-decamelizeMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-invert-kvMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-is-bufferMageia:5 |
before 1.1.0-1.mga5 | 1.1.0-1.mga5 |
Show 16 moreShow less
| Package | Affected | Fixed |
|---|---|---|
nodejs-is-fullwidth-code-pointMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-kind-ofMageia:5 |
before 2.0.1-1.mga5 | 2.0.1-1.mga5 |
nodejs-lcidMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-longestMageia:5 |
before 1.0.1-1.mga5 | 1.0.1-1.mga5 |
nodejs-minimistMageia:5 |
before 1.2.0-1.mga5 | 1.2.0-1.mga5 |
nodejs-number-is-nanMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-os-localeMageia:5 |
before 1.4.0-1.mga5 | 1.4.0-1.mga5 |
nodejs-repeat-stringMageia:5 |
before 1.5.2-1.mga5 | 1.5.2-1.mga5 |
nodejs-right-alignMageia:5 |
before 0.1.3-1.mga5 | 0.1.3-1.mga5 |
nodejs-source-mapMageia:5 |
before 0.5.1-1.1.mga5 | 0.5.1-1.1.mga5 |
nodejs-string-widthMageia:5 |
before 1.0.1-6.mga5 | 1.0.1-6.mga5 |
nodejs-strip-ansiMageia:5 |
before 3.0.0-1.mga5 | 3.0.0-1.mga5 |
nodejs-window-sizeMageia:5 |
before 0.1.2-1.mga5 | 0.1.2-1.mga5 |
nodejs-wrap-ansiMageia:5 |
before 1.0.0-1.mga5 | 1.0.0-1.mga5 |
nodejs-y18nMageia:5 |
before 3.2.0-1.mga5 | 3.2.0-1.mga5 |
nodejs-yargsMageia:5 |
before 3.28.0-2.mga5 | 3.28.0-2.mga5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
MGASA-2015-0454 is a vulnerability with no CVSS score yet in uglify-js, published November 19, 2015. No source lists public exploit code. Fixed in uglify-js 2.4.24-3.mga5.