Every CVE Search/ Get API key

CVE-2012-2125

RubyGems HTTPS to HTTP redirect

5.8 MediumFix available

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Exploit likelihood

2.47%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
CVE-2012-2125
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
CVE-2012-2125
Updated
2026-11-02
EUVDEUVD-2022-1878 No score

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
EUVD-2022-1878
Updated
2026-11-03
GitHub AdvisoriesGHSA-228f-g3h7-3fj3 No score

RubyGems HTTPS to HTTP redirect

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
GHSA-228f-g3h7-3fj3
Updated
2026-11-02
OSV No score

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
CVE-2012-2125
Updated
2026-11-02
OSVDEBIAN-CVE-2012-2125 No score

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
DEBIAN-CVE-2012-2125
Updated
2026-11-02
OSVGHSA-228f-g3h7-3fj3 No score

RubyGems HTTPS to HTTP redirect

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
GHSA-228f-g3h7-3fj3
Updated
2026-11-02
OSVUBUNTU-CVE-2012-2125 No score

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Record
UBUNTU-CVE-2012-2125
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rubygems-update
RubyGems
before 1.8.23
1.8.23
rubygems
Debian:12
before 1.8.24-1
1.8.24-1
rubygems
Debian:13
before 1.8.24-1
1.8.24-1
rubygems
Debian:14
before 1.8.24-1
1.8.24-1
rubygems-update
RubyGems
before 1.8.23, plus listed versions
0.8.100.8.110.8.30.8.40.8.5
Show 45 moreShow less
0.8.60.8.80.9.00.9.10.9.20.9.30.9.40.9.51.0.01.0.11.1.01.1.11.2.01.3.01.3.11.3.21.3.31.3.41.3.51.3.61.3.71.4.01.4.11.4.21.5.01.5.21.5.31.6.01.6.11.6.21.7.01.7.11.7.21.8.01.8.11.8.101.8.111.8.121.8.131.8.141.8.151.8.161.8.171.8.181.8.19
1.8.23
rubygems
Red Hat:openshift:1.2::el6
From an advisory covering 2 CVEs
before 0:1.8.24-4.el6op
0:1.8.24-4.el6op
rubygems
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:1.3.7-4.el6_4
0:1.3.7-4.el6_4
rubygems
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:1.3.7-4.el6_4
0:1.3.7-4.el6_4
rubygems
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:1.3.7-4.el6_4
0:1.3.7-4.el6_4
rubygems
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:1.3.7-4.el6_4
0:1.3.7-4.el6_4
Show 4 moreShow less
Affected packages
PackageAffectedFixed
rubygems
Red Hat:enterprise_mrg:2:computenode:el6
From an advisory covering 7 CVEs
before 0:1.8.23.2-1.el6
0:1.8.23.2-1.el6
cumin
Red Hat:enterprise_mrg:2:server:el6
From an advisory covering 7 CVEs
before 0:0.1.5787-4.el6
0:0.1.5787-4.el6
rubygems
Red Hat:enterprise_mrg:2:server:el6
From an advisory covering 7 CVEs
before 0:1.8.23.2-1.el6
0:1.8.23.2-1.el6
jruby
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
1.5.6-5ubuntu11.5.6-61.5.6-71.5.6-9+deb8u2build0.14.04.1~esm2
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2125 is a medium vulnerability (CVSS 5.8) in Rubygems, published April 20, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.47%, the 84th percentile. Fixed in rubygems-update 1.8.23.

References

Show 45 moreShow less
This page doesn't list everything

Left out here: 11 versions. The JSON record has them.

MoveEnter Open