Every CVE Search/ Get API key

USN-2950-5

samba regression

No scoreFix available

USN-2950-1 fixed vulnerabilities in Samba. USN-2950-3 updated Samba to version 4.3.9, which introduced a regression when using the ntlm_auth tool. This update fixes the problem.

Original advisory details:

Jouni Knuutinen discovered that Samba contained multiple flaws in the DCE/RPC implementation. A remote attacker could use this issue to perform a denial of service, downgrade secure connections by performing a machine-in-the-middle attack, or possibly execute arbitrary code. (CVE-2015-5370)

Stefan Metzmacher discovered that Samba contained multiple flaws in the NTLMSSP authentication implementation. A remote attacker could use this issue to downgrade connections to plain text by performing a machine-in-the-middle attack. (CVE-2016-2110)

Alberto Solino discovered that a Samba domain controller would establish a secure connection to a server with a spoofed computer name. A remote attacker could use this issue to obtain sensitive information. (CVE-2016-2111)

Stefan Metzmacher discovered that the Samba LDAP implementation did not enforce integrity protection. A remote attacker could use this issue to hijack LDAP connections by performing a machine-in-the-middle attack. (CVE-2016-2112)

Stefan Metzmacher discovered that Samba did not validate TLS certificates. A remote attacker could use this issue to spoof a Samba server. (CVE-2016-2113)

Stefan Metzmacher discovered that Samba did not enforce SMB signing even if configured to. A remote attacker could use this issue to perform a machine-in-the-middle attack. (CVE-2016-2114)

Stefan Metzmacher discovered that Samba did not enable integrity protection for IPC traffic. A remote attacker could use this issue to perform a machine-in-the-middle attack. (CVE-2016-2115)

Stefan Metzmacher discovered that Samba incorrectly handled the MS-SAMR and MS-LSAD protocols. A remote attacker could use this flaw with a machine-in-the-middle attack to impersonate users and obtain sensitive information from the Security Account Manager database. This flaw is known as Badlock. (CVE-2016-2118)

Samba has been updated to 4.3.8 in Ubuntu 14.04 LTS and Ubuntu 15.10. Ubuntu 12.04 LTS has been updated to 3.6.25 with backported security fixes.

In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes. Configuration changes may be required in certain environments.

What each source reports

OSV No score

samba regression

USN-2950-1 fixed vulnerabilities in Samba. USN-2950-3 updated Samba to version 4.3.9, which introduced a regression when using the ntlm_auth tool. This update fixes the problem.

Original advisory details:

Jouni Knuutinen discovered that Samba contained multiple flaws in the DCE/RPC implementation. A remote attacker could use this issue to perform a denial of service, downgrade secure connections by performing a machine-in-the-middle attack, or possibly execute arbitrary code. (CVE-2015-5370)

Stefan Metzmacher discovered that Samba contained multiple flaws in the NTLMSSP authentication implementation. A remote attacker could use this issue to downgrade connections to plain text by performing a machine-in-the-middle attack. (CVE-2016-2110)

Alberto Solino discovered that a Samba domain controller would establish a secure connection to a server with a spoofed computer name. A remote attacker could use this issue to obtain sensitive information. (CVE-2016-2111)

Stefan Metzmacher discovered that the Samba LDAP implementation did not enforce integrity protection. A remote attacker could use this issue to hijack LDAP connections by performing a machine-in-the-middle attack. (CVE-2016-2112)

Stefan Metzmacher discovered that Samba did not validate TLS certificates. A remote attacker could use this issue to spoof a Samba server. (CVE-2016-2113)

Stefan Metzmacher discovered that Samba did not enforce SMB signing even if configured to. A remote attacker could use this issue to perform a machine-in-the-middle attack. (CVE-2016-2114)

Stefan Metzmacher discovered that Samba did not enable integrity protection for IPC traffic. A remote attacker could use this issue to perform a machine-in-the-middle attack. (CVE-2016-2115)

Stefan Metzmacher discovered that Samba incorrectly handled the MS-SAMR and MS-LSAD protocols. A remote attacker could use this flaw with a machine-in-the-middle attack to impersonate users and obtain sensitive information from the Security Account Manager database. This flaw is known as Badlock. (CVE-2016-2118)

Samba has been updated to 4.3.8 in Ubuntu 14.04 LTS and Ubuntu 15.10. Ubuntu 12.04 LTS has been updated to 3.6.25 with backported security fixes.

In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes. Configuration changes may be required in certain environments.

Record
USN-2950-5
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
samba
Ubuntu:14.04:LTS
before 2:4.3.9+dfsg-0ubuntu0.14.04.3, plus listed versions
2:3.6.18-1ubuntu32:4.0.10+dfsg-4ubuntu22:4.0.13+dfsg-1ubuntu12:4.1.3+dfsg-2ubuntu22:4.1.3+dfsg-2ubuntu3
Show 17 moreShow less
2:4.1.3+dfsg-2ubuntu42:4.1.3+dfsg-2ubuntu52:4.1.6+dfsg-1ubuntu12:4.1.6+dfsg-1ubuntu22:4.1.6+dfsg-1ubuntu2.14.04.12:4.1.6+dfsg-1ubuntu2.14.04.22:4.1.6+dfsg-1ubuntu2.14.04.32:4.1.6+dfsg-1ubuntu2.14.04.42:4.1.6+dfsg-1ubuntu2.14.04.52:4.1.6+dfsg-1ubuntu2.14.04.72:4.1.6+dfsg-1ubuntu2.14.04.82:4.1.6+dfsg-1ubuntu2.14.04.92:4.1.6+dfsg-1ubuntu2.14.04.112:4.1.6+dfsg-1ubuntu2.14.04.122:4.1.6+dfsg-1ubuntu2.14.04.132:4.3.8+dfsg-0ubuntu0.14.04.22:4.3.9+dfsg-0ubuntu0.14.04.1
2:4.3.9+dfsg-0ubuntu0.14.04.3
samba
Ubuntu:16.04:LTS
before 2:4.3.9+dfsg-0ubuntu0.16.04.2, plus listed versions
2:4.1.17+dfsg-4ubuntu22:4.1.20+dfsg-1ubuntu12:4.1.20+dfsg-1ubuntu22:4.1.20+dfsg-1ubuntu32:4.1.20+dfsg-1ubuntu5
Show 6 moreShow less
2:4.3.3+dfsg-1ubuntu12:4.3.3+dfsg-1ubuntu22:4.3.3+dfsg-1ubuntu32:4.3.6+dfsg-1ubuntu12:4.3.8+dfsg-0ubuntu12:4.3.9+dfsg-0ubuntu0.16.04.1
2:4.3.9+dfsg-0ubuntu0.16.04.2

History

History
RecordedChangedSources
first indexedOSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

USN-2950-5 is a vulnerability with no CVSS score yet in samba, published May 25, 2016. No source lists public exploit code. Fixed in samba 2:4.3.9+dfsg-0ubuntu0.14.04.3.

References

MoveEnter Open