USN-3135-2
gst-plugins-good0.10, gst-plugins-good1.0 vulnerability
USN-3135-1 fixed a vulnerability in GStreamer Good Plugins. The original security fix was incomplete. This update fixes the problem.
Original advisory details:
Chris Evans discovered that GStreamer Good Plugins did not correctly handle malformed FLC movie files. If a user were tricked into opening a crafted FLC movie file with a GStreamer application, an attacker could cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program.
What each source reports
OSV No score
gst-plugins-good0.10, gst-plugins-good1.0 vulnerability
USN-3135-1 fixed a vulnerability in GStreamer Good Plugins. The original security fix was incomplete. This update fixes the problem.
Original advisory details:
Chris Evans discovered that GStreamer Good Plugins did not correctly handle malformed FLC movie files. If a user were tricked into opening a crafted FLC movie file with a GStreamer application, an attacker could cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program.
- Record
USN-3135-2- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gst-plugins-good0.10Ubuntu:14.04:LTS |
before 0.10.31-3+nmu1ubuntu5.2, plus listed versions 0.10.31-3+nmu1ubuntu30.10.31-3+nmu1ubuntu40.10.31-3+nmu1ubuntu50.10.31-3+nmu1ubuntu5.1 |
0.10.31-3+nmu1ubuntu5.2 |
gst-plugins-good1.0Ubuntu:14.04:LTS |
before 1.2.4-1~ubuntu1.3, plus listed versions 1.2.0-1ubuntu11.2.1-1ubuntu11.2.1-1ubuntu21.2.2-1ubuntu11.2.3-1ubuntu11.2.3-1ubuntu21.2.4-1~ubuntu11.2.4-1~ubuntu1.1 |
1.2.4-1~ubuntu1.3 |
gst-plugins-good1.0Ubuntu:16.04:LTS |
before 1.8.2-1ubuntu0.3, plus listed versions 1.6.0-1ubuntu11.6.1-1ubuntu11.6.2-1ubuntu11.7.1-1ubuntu11.7.2-1ubuntu1 Show 6 moreShow less1.7.90-1ubuntu11.7.91-1ubuntu11.8.0-1ubuntu11.8.1-1ubuntu0.11.8.2-1ubuntu0.11.8.2-1ubuntu0.2 |
1.8.2-1ubuntu0.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-3135-2 is a vulnerability with no CVSS score yet in gst-plugins-good0.10, published November 28, 2016. No source lists public exploit code. Fixed in gst-plugins-good0.10 0.10.31-3+nmu1ubuntu5.2.