USN-3831-2
ghostscript regression
USN-3831-1 fixed vulnerabilities in Ghostscript. Ghostscript 9.26 introduced a regression when used with certain options. This update fixes the problem.
Original advisory details:
It was discovered that Ghostscript contained multiple security issues. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use these issues to access arbitrary files, execute arbitrary code, or cause a denial of service.
What each source reports
OSV No score
ghostscript regression
USN-3831-1 fixed vulnerabilities in Ghostscript. Ghostscript 9.26 introduced a regression when used with certain options. This update fixes the problem.
Original advisory details:
It was discovered that Ghostscript contained multiple security issues. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use these issues to access arbitrary files, execute arbitrary code, or cause a denial of service.
- Record
USN-3831-2- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ghostscriptUbuntu:14.04:LTS |
before 9.26~dfsg+0-0ubuntu0.14.04.3, plus listed versions 9.10~dfsg-0ubuntu29.10~dfsg-0ubuntu39.10~dfsg-0ubuntu49.10~dfsg-0ubuntu59.10~dfsg-0ubuntu6 Show 19 moreShow less9.10~dfsg-0ubuntu79.10~dfsg-0ubuntu89.10~dfsg-0ubuntu99.10~dfsg-0ubuntu109.10~dfsg-0ubuntu10.19.10~dfsg-0ubuntu10.29.10~dfsg-0ubuntu10.39.10~dfsg-0ubuntu10.49.10~dfsg-0ubuntu10.59.10~dfsg-0ubuntu10.69.10~dfsg-0ubuntu10.79.10~dfsg-0ubuntu10.99.10~dfsg-0ubuntu10.109.10~dfsg-0ubuntu10.129.10~dfsg-0ubuntu10.139.25~dfsg+1-0ubuntu0.14.04.19.25~dfsg+1-0ubuntu0.14.04.29.25~dfsg+1-0ubuntu0.14.04.39.26~dfsg+0-0ubuntu0.14.04.1 |
9.26~dfsg+0-0ubuntu0.14.04.3 |
ghostscriptUbuntu:16.04:LTS |
before 9.26~dfsg+0-0ubuntu0.16.04.3, plus listed versions 9.16~dfsg~0-0ubuntu39.16~dfsg~0-0ubuntu49.18~dfsg~0-0ubuntu19.18~dfsg~0-0ubuntu29.18~dfsg~0-0ubuntu2.2 Show 10 moreShow less9.18~dfsg~0-0ubuntu2.39.18~dfsg~0-0ubuntu2.49.18~dfsg~0-0ubuntu2.69.18~dfsg~0-0ubuntu2.79.18~dfsg~0-0ubuntu2.89.18~dfsg~0-0ubuntu2.99.25~dfsg+1-0ubuntu0.16.04.19.25~dfsg+1-0ubuntu0.16.04.29.25~dfsg+1-0ubuntu0.16.04.39.26~dfsg+0-0ubuntu0.16.04.1 |
9.26~dfsg+0-0ubuntu0.16.04.3 |
ghostscriptUbuntu:18.04:LTS |
before 9.26~dfsg+0-0ubuntu0.18.04.3, plus listed versions 9.21~dfsg+1-0ubuntu39.22~dfsg+1-0ubuntu19.22~dfsg+1-0ubuntu1.19.22~dfsg+1-0ubuntu1.29.25~dfsg+1-0ubuntu0.18.04.19.25~dfsg+1-0ubuntu0.18.04.29.26~dfsg+0-0ubuntu0.18.04.1 |
9.26~dfsg+0-0ubuntu0.18.04.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-3831-2 is a vulnerability with no CVSS score yet in ghostscript, published December 6, 2018. No source lists public exploit code. Fixed in ghostscript 9.26~dfsg+0-0ubuntu0.14.04.3.