USN-4170-2
whoopsie regression
USN-4170-1 fixed a vulnerability in Whoopsie. The update caused Whoopsie to crash when sending reports. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
Kevin Backhouse discovered Whoopsie incorrectly handled very large crash reports. A local attacker could possibly use this issue to cause a denial of service, expose sensitive information or execute code as the whoopsie user.
What each source reports
OSV No score
whoopsie regression
USN-4170-1 fixed a vulnerability in Whoopsie. The update caused Whoopsie to crash when sending reports. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
Kevin Backhouse discovered Whoopsie incorrectly handled very large crash reports. A local attacker could possibly use this issue to cause a denial of service, expose sensitive information or execute code as the whoopsie user.
- Record
USN-4170-2- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
whoopsieUbuntu:16.04:LTS |
before 0.2.52.5ubuntu0.3, plus listed versions 0.2.490.2.500.2.510.2.520.2.52.1 Show 6 moreShow less0.2.52.20.2.52.30.2.52.40.2.52.50.2.52.5ubuntu0.10.2.52.5ubuntu0.2 |
0.2.52.5ubuntu0.3 |
whoopsieUbuntu:18.04:LTS |
before 0.2.62ubuntu0.3, plus listed versions 0.2.580.2.590.2.59build10.2.600.2.620.2.62ubuntu0.10.2.62ubuntu0.2 |
0.2.62ubuntu0.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-4170-2 is a vulnerability with no CVSS score yet in whoopsie, published October 30, 2019. No source lists public exploit code. Fixed in whoopsie 0.2.52.5ubuntu0.3.