USN-6156-2
sssd regression
USN-6156-1 fixed a vulnerability in SSSD. In certain environments, not all packages ended up being upgraded at the same time, resulting in authentication failures when the PAM module was being used.
This update fixes the problem. We apologize for the inconvenience.
Original advisory details:
It was discovered that SSSD incorrrectly sanitized certificate data used in LDAP filters. When using this issue in combination with FreeIPA, a remote attacker could possibly use this issue to escalate privileges.
What each source reports
OSV No score
sssd regression
USN-6156-1 fixed a vulnerability in SSSD. In certain environments, not all packages ended up being upgraded at the same time, resulting in authentication failures when the PAM module was being used.
This update fixes the problem. We apologize for the inconvenience.
Original advisory details:
It was discovered that SSSD incorrrectly sanitized certificate data used in LDAP filters. When using this issue in combination with FreeIPA, a remote attacker could possibly use this issue to escalate privileges.
- Record
USN-6156-2- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sssdUbuntu:20.04:LTS |
before 2.2.3-3ubuntu0.12, plus listed versions 2.2.0-4ubuntu12.2.2-12.2.2-1ubuntu12.2.3-1.1ubuntu12.2.3-2 Show 11 moreShow less2.2.3-32.2.3-3ubuntu0.12.2.3-3ubuntu0.22.2.3-3ubuntu0.32.2.3-3ubuntu0.42.2.3-3ubuntu0.62.2.3-3ubuntu0.72.2.3-3ubuntu0.82.2.3-3ubuntu0.92.2.3-3ubuntu0.102.2.3-3ubuntu0.11 |
2.2.3-3ubuntu0.12 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-6156-2 is a vulnerability with no CVSS score yet in sssd, published June 16, 2023. No source lists public exploit code. Fixed in sssd 2.2.3-3ubuntu0.12.