USN-6727-2
nss regression
USN-6727-1 fixed vulnerabilities in NSS. The update introduced a regression when trying to load security modules on Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
It was discovered that NSS incorrectly handled padding when checking PKCS#1 certificates. A remote attacker could possibly use this issue to perform Bleichenbacher-like attacks and recover private data. This issue only affected Ubuntu 20.04 LTS. (CVE-2023-4421)
It was discovered that NSS had a timing side-channel when performing RSA decryption. A remote attacker could possibly use this issue to recover private data. (CVE-2023-5388)
It was discovered that NSS had a timing side-channel when using certain NIST curves. A remote attacker could possibly use this issue to recover private data. (CVE-2023-6135)
The NSS package contained outdated CA certificates. This update refreshes the NSS package to version 3.98 which includes the latest CA certificate bundle and other security improvements.
What each source reports
OSV No score
nss regression
USN-6727-1 fixed vulnerabilities in NSS. The update introduced a regression when trying to load security modules on Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
It was discovered that NSS incorrectly handled padding when checking PKCS#1 certificates. A remote attacker could possibly use this issue to perform Bleichenbacher-like attacks and recover private data. This issue only affected Ubuntu 20.04 LTS. (CVE-2023-4421)
It was discovered that NSS had a timing side-channel when performing RSA decryption. A remote attacker could possibly use this issue to recover private data. (CVE-2023-5388)
It was discovered that NSS had a timing side-channel when using certain NIST curves. A remote attacker could possibly use this issue to recover private data. (CVE-2023-6135)
The NSS package contained outdated CA certificates. This update refreshes the NSS package to version 3.98 which includes the latest CA certificate bundle and other security improvements.
- Record
USN-6727-2- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nssUbuntu:20.04:LTS |
before 2:3.98-0ubuntu0.20.04.2, plus listed versions 2:3.45-1ubuntu22:3.47-1ubuntu12:3.47-1ubuntu22:3.48-1ubuntu12:3.49.1-1ubuntu1 Show 9 moreShow less2:3.49.1-1ubuntu1.12:3.49.1-1ubuntu1.22:3.49.1-1ubuntu1.42:3.49.1-1ubuntu1.52:3.49.1-1ubuntu1.62:3.49.1-1ubuntu1.72:3.49.1-1ubuntu1.82:3.49.1-1ubuntu1.92:3.98-0ubuntu0.20.04.1 |
2:3.98-0ubuntu0.20.04.2 |
nssUbuntu:22.04:LTS |
before 2:3.98-0ubuntu0.22.04.2, plus listed versions 2:3.68-1ubuntu12:3.68-1ubuntu22:3.68.2-0ubuntu12:3.68.2-0ubuntu1.12:3.68.2-0ubuntu1.22:3.98-0ubuntu0.22.04.1 |
2:3.98-0ubuntu0.22.04.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-6727-2 is a vulnerability with no CVSS score yet in nss, published April 11, 2024. No source lists public exploit code. Fixed in nss 2:3.98-0ubuntu0.20.04.2.