USN-7117-2
needrestart regression
USN-7117-1 fixed vulnerabilities in needrestart. The update introduced a regression in needrestart. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
Qualys discovered that needrestart passed unsanitized data to a library (libmodule-scandeps-perl) which expects safe input. A local attacker could possibly use this issue to execute arbitrary code as root. (CVE-2024-11003)
Qualys discovered that the library libmodule-scandeps-perl incorrectly parsed perl code. This could allow a local attacker to execute arbitrary shell commands. (CVE-2024-10224)
Qualys discovered that needrestart incorrectly used the PYTHONPATH environment variable to spawn a new Python interpreter. A local attacker could possibly use this issue to execute arbitrary code as root. (CVE-2024-48990)
Qualys discovered that needrestart incorrectly checked the path to the Python interpreter. A local attacker could possibly use this issue to win a race condition and execute arbitrary code as root. (CVE-2024-48991)
Qualys discovered that needrestart incorrectly used the RUBYLIB environment variable to spawn a new Ruby interpreter. A local attacker could possibly use this issue to execute arbitrary code as root. (CVE-2024-48992)
What each source reports
OSV No score
needrestart regression
USN-7117-1 fixed vulnerabilities in needrestart. The update introduced a regression in needrestart. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
Qualys discovered that needrestart passed unsanitized data to a library (libmodule-scandeps-perl) which expects safe input. A local attacker could possibly use this issue to execute arbitrary code as root. (CVE-2024-11003)
Qualys discovered that the library libmodule-scandeps-perl incorrectly parsed perl code. This could allow a local attacker to execute arbitrary shell commands. (CVE-2024-10224)
Qualys discovered that needrestart incorrectly used the PYTHONPATH environment variable to spawn a new Python interpreter. A local attacker could possibly use this issue to execute arbitrary code as root. (CVE-2024-48990)
Qualys discovered that needrestart incorrectly checked the path to the Python interpreter. A local attacker could possibly use this issue to win a race condition and execute arbitrary code as root. (CVE-2024-48991)
Qualys discovered that needrestart incorrectly used the RUBYLIB environment variable to spawn a new Ruby interpreter. A local attacker could possibly use this issue to execute arbitrary code as root. (CVE-2024-48992)
- Record
USN-7117-2- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
needrestartUbuntu:Pro:16.04:LTS |
before 2.6-1ubuntu0.1~esm2, plus listed versions 2.1-12.3-22.4-12.5-12.6-12.6-1ubuntu0.1~esm1 |
2.6-1ubuntu0.1~esm2 |
needrestartUbuntu:Pro:18.04:LTS |
before 3.1-1ubuntu0.1+esm2, plus listed versions 2.11-43.0-13.1-13.1-1ubuntu0.13.1-1ubuntu0.1+esm1 |
3.1-1ubuntu0.1+esm2 |
needrestartUbuntu:Pro:20.04:LTS |
before 3.4-6ubuntu0.1+esm2, plus listed versions 3.4-53.4-63.4-6ubuntu0.13.4-6ubuntu0.1+esm1 |
3.4-6ubuntu0.1+esm2 |
needrestartUbuntu:22.04:LTS |
before 3.5-5ubuntu2.3, plus listed versions 3.5-4ubuntu23.5-5ubuntu13.5-5ubuntu23.5-5ubuntu2.13.5-5ubuntu2.2 |
3.5-5ubuntu2.3 |
needrestartUbuntu:24.04:LTS |
before 3.6-7ubuntu4.4, plus listed versions 3.6-53.6-63.6-73.6-7ubuntu33.6-7ubuntu43.6-7ubuntu4.13.6-7ubuntu4.3 |
3.6-7ubuntu4.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-7117-2 is a vulnerability with no CVSS score yet in needrestart, published November 26, 2024. No source lists public exploit code. Fixed in needrestart 2.6-1ubuntu0.1~esm2.