USN-7626-3
git regression
USN-7626-1 fixed vulnerabilities in Git. The updates for CVE-2025-27613 and CVE-2025-46835 caused Gitk and Git GUI to not work properly on Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS, and were disabled in USN-7626-2. The problematic updates for the aforementioned CVEs have now been corrected and reinstated in this update.
We apologize for the inconvenience.
Original advisory details:
Avi Halachmi discovered that Git incorrectly managed file modification constraints with Gitk. An attacker could possibly use this issue to create or write to arbitrary files on the system. (CVE-2025-27613)
Avi Halachmi discovered that Git incorrectly handled arguments when invoking the Gitk utility. If a user were tricked into cloning a malicious Git repository, an attacker could possibly use this issue to run arbitrary commands. This issue only affected Ubuntu 24.04 LTS, Ubuntu 24.10, and Ubuntu 25.04. (CVE-2025-27614)
Johannes Sixt discovered that Git incorrectly managed file modification constraints with Git GUI. If a user were tricked into editing a file in a malicious Git repository, an attacker could possibly use this issue to create or write to arbitrary files on the system. (CVE-2025-46835)
David Leadbeater discovered that Git incorrectly stripped CRLF characters when editing configuration files. An attacker could possibly use this issue to execute arbitrary code. (CVE-2025-48384)
David Leadbeater discovered that Git incorrectly handled verification when fetching remote Git repositories. An attacker could possibly use this issue to perform protocol injection, leading to arbitrary code execution. This issue only affected Ubuntu 24.04 LTS, Ubuntu 24.10, and Ubuntu 25.04. (CVE-2025-48385)
David Leadbeater discovered that Git incorrectly handled memory with the wincred credential helper. An attacker could possibly use this issue to cause a denial of service. (CVE-2025-48386)
What each source reports
OSV No score
git regression
USN-7626-1 fixed vulnerabilities in Git. The updates for CVE-2025-27613 and CVE-2025-46835 caused Gitk and Git GUI to not work properly on Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS, and were disabled in USN-7626-2. The problematic updates for the aforementioned CVEs have now been corrected and reinstated in this update.
We apologize for the inconvenience.
Original advisory details:
Avi Halachmi discovered that Git incorrectly managed file modification constraints with Gitk. An attacker could possibly use this issue to create or write to arbitrary files on the system. (CVE-2025-27613)
Avi Halachmi discovered that Git incorrectly handled arguments when invoking the Gitk utility. If a user were tricked into cloning a malicious Git repository, an attacker could possibly use this issue to run arbitrary commands. This issue only affected Ubuntu 24.04 LTS, Ubuntu 24.10, and Ubuntu 25.04. (CVE-2025-27614)
Johannes Sixt discovered that Git incorrectly managed file modification constraints with Git GUI. If a user were tricked into editing a file in a malicious Git repository, an attacker could possibly use this issue to create or write to arbitrary files on the system. (CVE-2025-46835)
David Leadbeater discovered that Git incorrectly stripped CRLF characters when editing configuration files. An attacker could possibly use this issue to execute arbitrary code. (CVE-2025-48384)
David Leadbeater discovered that Git incorrectly handled verification when fetching remote Git repositories. An attacker could possibly use this issue to perform protocol injection, leading to arbitrary code execution. This issue only affected Ubuntu 24.04 LTS, Ubuntu 24.10, and Ubuntu 25.04. (CVE-2025-48385)
David Leadbeater discovered that Git incorrectly handled memory with the wincred credential helper. An attacker could possibly use this issue to cause a denial of service. (CVE-2025-48386)
- Record
USN-7626-3- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gitUbuntu:Pro:16.04:LTS |
before 1:2.7.4-0ubuntu1.10+esm11, plus listed versions 1:2.5.0-11:2.6.2-11:2.6.3-11:2.6.4-11:2.7.0~rc3-1 Show 22 moreShow less1:2.7.0-11:2.7.3-0ubuntu11:2.7.4-0ubuntu11:2.7.4-0ubuntu1.11:2.7.4-0ubuntu1.21:2.7.4-0ubuntu1.31:2.7.4-0ubuntu1.41:2.7.4-0ubuntu1.51:2.7.4-0ubuntu1.61:2.7.4-0ubuntu1.71:2.7.4-0ubuntu1.81:2.7.4-0ubuntu1.91:2.7.4-0ubuntu1.101:2.7.4-0ubuntu1.10+esm11:2.7.4-0ubuntu1.10+esm31:2.7.4-0ubuntu1.10+esm41:2.7.4-0ubuntu1.10+esm51:2.7.4-0ubuntu1.10+esm61:2.7.4-0ubuntu1.10+esm71:2.7.4-0ubuntu1.10+esm81:2.7.4-0ubuntu1.10+esm91:2.7.4-0ubuntu1.10+esm10 |
1:2.7.4-0ubuntu1.10+esm11 |
gitUbuntu:Pro:18.04:LTS |
before 1:2.17.1-1ubuntu0.18+esm4, plus listed versions 1:2.14.1-1ubuntu41:2.15.1-1ubuntu21:2.17.0-1ubuntu11:2.17.1-1ubuntu0.11:2.17.1-1ubuntu0.3 Show 18 moreShow less1:2.17.1-1ubuntu0.41:2.17.1-1ubuntu0.51:2.17.1-1ubuntu0.61:2.17.1-1ubuntu0.71:2.17.1-1ubuntu0.81:2.17.1-1ubuntu0.91:2.17.1-1ubuntu0.101:2.17.1-1ubuntu0.111:2.17.1-1ubuntu0.121:2.17.1-1ubuntu0.131:2.17.1-1ubuntu0.141:2.17.1-1ubuntu0.151:2.17.1-1ubuntu0.161:2.17.1-1ubuntu0.171:2.17.1-1ubuntu0.181:2.17.1-1ubuntu0.18+esm11:2.17.1-1ubuntu0.18+esm21:2.17.1-1ubuntu0.18+esm3 |
1:2.17.1-1ubuntu0.18+esm4 |
gitUbuntu:Pro:20.04:LTS |
before 1:2.25.1-1ubuntu3.14+esm3, plus listed versions 1:2.20.1-2ubuntu11:2.24.0-1ubuntu11:2.24.0-1ubuntu21:2.25.0-1ubuntu11:2.25.1-1ubuntu1 Show 17 moreShow less1:2.25.1-1ubuntu21:2.25.1-1ubuntu31:2.25.1-1ubuntu3.11:2.25.1-1ubuntu3.21:2.25.1-1ubuntu3.31:2.25.1-1ubuntu3.41:2.25.1-1ubuntu3.51:2.25.1-1ubuntu3.61:2.25.1-1ubuntu3.71:2.25.1-1ubuntu3.81:2.25.1-1ubuntu3.101:2.25.1-1ubuntu3.111:2.25.1-1ubuntu3.121:2.25.1-1ubuntu3.131:2.25.1-1ubuntu3.141:2.25.1-1ubuntu3.14+esm11:2.25.1-1ubuntu3.14+esm2 |
1:2.25.1-1ubuntu3.14+esm3 |
gitUbuntu:22.04:LTS |
before 1:2.34.1-1ubuntu1.15, plus listed versions 1:2.32.0-1ubuntu11:2.33.1-1ubuntu11:2.34.1-1ubuntu11:2.34.1-1ubuntu1.11:2.34.1-1ubuntu1.2 Show 10 moreShow less1:2.34.1-1ubuntu1.41:2.34.1-1ubuntu1.51:2.34.1-1ubuntu1.61:2.34.1-1ubuntu1.81:2.34.1-1ubuntu1.91:2.34.1-1ubuntu1.101:2.34.1-1ubuntu1.111:2.34.1-1ubuntu1.121:2.34.1-1ubuntu1.131:2.34.1-1ubuntu1.14 |
1:2.34.1-1ubuntu1.15 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
USN-7626-3 is a vulnerability with no CVSS score yet in git, published July 10, 2025. No source lists public exploit code. Fixed in git 1:2.7.4-0ubuntu1.10+esm11.