Every CVE Search/ Get API key

USN-8543-2

wget regression

No scoreFix available

USN-8543-1 fixed vulnerabilities in Wget. The update for CVE-2026-58472 was incomplete and could introduce a regression. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Wget mishandled semicolons in the userinfo subcomponent of a URL. A remote attacker could possibly use this issue to trick a user into connecting to a different host than intended. This issue only affected Ubuntu 14.04 LTS. (CVE-2024-38428)

It was discovered that Wget incorrectly handled Metalink documents containing a whitespace-only URL. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 26.04 LTS. (CVE-2026-58469)

It was discovered that Wget incorrectly handled Content-Range header values, leading to an integer overflow. A remote attacker could possibly use this issue to cause download desynchronization. (CVE-2026-58470)

It was discovered that Wget incorrectly handled character set conversion of server-supplied filenames. A remote attacker could possibly use this issue to cause a denial of service or possibly execute arbitrary code. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 26.04 LTS. (CVE-2026-58471)

It was discovered that Wget incorrectly handled HTML attributes requiring entity encoding. A remote attacker could possibly use this issue to cause a denial of service or possibly execute arbitrary code. (CVE-2026-58472)

What each source reports

OSV No score

wget regression

USN-8543-1 fixed vulnerabilities in Wget. The update for CVE-2026-58472 was incomplete and could introduce a regression. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Wget mishandled semicolons in the userinfo subcomponent of a URL. A remote attacker could possibly use this issue to trick a user into connecting to a different host than intended. This issue only affected Ubuntu 14.04 LTS. (CVE-2024-38428)

It was discovered that Wget incorrectly handled Metalink documents containing a whitespace-only URL. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 26.04 LTS. (CVE-2026-58469)

It was discovered that Wget incorrectly handled Content-Range header values, leading to an integer overflow. A remote attacker could possibly use this issue to cause download desynchronization. (CVE-2026-58470)

It was discovered that Wget incorrectly handled character set conversion of server-supplied filenames. A remote attacker could possibly use this issue to cause a denial of service or possibly execute arbitrary code. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 26.04 LTS. (CVE-2026-58471)

It was discovered that Wget incorrectly handled HTML attributes requiring entity encoding. A remote attacker could possibly use this issue to cause a denial of service or possibly execute arbitrary code. (CVE-2026-58472)

Record
USN-8543-2
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
wget
Ubuntu:Pro:14.04:LTS
before 1.15-1ubuntu1.14.04.5+esm4, plus listed versions
1.14-2ubuntu11.14-5ubuntu11.15-1ubuntu11.15-1ubuntu1.14.04.11.15-1ubuntu1.14.04.2
Show 5 moreShow less
1.15-1ubuntu1.14.04.31.15-1ubuntu1.14.04.41.15-1ubuntu1.14.04.51.15-1ubuntu1.14.04.5+esm21.15-1ubuntu1.14.04.5+esm3
1.15-1ubuntu1.14.04.5+esm4
wget
Ubuntu:Pro:16.04:LTS
before 1.17.1-1ubuntu1.5+esm5, plus listed versions
1.16.1-1ubuntu11.17.1-1ubuntu11.17.1-1ubuntu1.11.17.1-1ubuntu1.21.17.1-1ubuntu1.3
Show 5 moreShow less
1.17.1-1ubuntu1.41.17.1-1ubuntu1.51.17.1-1ubuntu1.5+esm11.17.1-1ubuntu1.5+esm31.17.1-1ubuntu1.5+esm4
1.17.1-1ubuntu1.5+esm5
wget
Ubuntu:Pro:18.04:LTS
before 1.19.4-1ubuntu2.2+esm5, plus listed versions
1.19.1-3ubuntu11.19.1-3ubuntu1.11.19.2-1ubuntu11.19.3-2ubuntu11.19.4-1ubuntu2
Show 5 moreShow less
1.19.4-1ubuntu2.11.19.4-1ubuntu2.21.19.4-1ubuntu2.2+esm11.19.4-1ubuntu2.2+esm31.19.4-1ubuntu2.2+esm4
1.19.4-1ubuntu2.2+esm5
wget
Ubuntu:Pro:20.04:LTS
before 1.20.3-1ubuntu2.1+esm4, plus listed versions
1.20.3-1ubuntu11.20.3-1ubuntu21.20.3-1ubuntu2.11.20.3-1ubuntu2.1+esm21.20.3-1ubuntu2.1+esm3
1.20.3-1ubuntu2.1+esm4
wget
Ubuntu:22.04:LTS
before 1.21.2-2ubuntu1.5, plus listed versions
1.21-1ubuntu31.21-1ubuntu41.21-1ubuntu51.21.2-2ubuntu11.21.2-2ubuntu1.11.21.2-2ubuntu1.31.21.2-2ubuntu1.4
1.21.2-2ubuntu1.5
wget
Ubuntu:24.04:LTS
before 1.21.4-1ubuntu4.5, plus listed versions
1.21.3-1ubuntu11.21.4-1ubuntu11.21.4-1ubuntu21.21.4-1ubuntu31.21.4-1ubuntu41.21.4-1ubuntu4.11.21.4-1ubuntu4.31.21.4-1ubuntu4.4
1.21.4-1ubuntu4.5
wget
Ubuntu:26.04:LTS
before 1.25.0-2ubuntu4.4, plus listed versions
1.25.0-2ubuntu31.25.0-2ubuntu41.25.0-2ubuntu4.21.25.0-2ubuntu4.3
1.25.0-2ubuntu4.4

History

History
RecordedChangedSources
first indexedOSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

USN-8543-2 is a vulnerability with no CVSS score yet in wget, published August 20, 2026. No source lists public exploit code. Fixed in wget 1.15-1ubuntu1.14.04.5+esm4.

References

MoveEnter Open