perl-Module-Load vulnerabilities (AlmaLinux)
10 vulnerabilities.
-
perl-Module-LoadAlmaLinux Perl versions before 5.40.5-RC1, from 5.41.0 before 5.42.3-RC1, from 5.43.0 before 5.43.10 produce silently incorrect regular expression matches when an alternation of more than 65535 fixed string bra… 9.1 Critical -
perl-Module-LoadAlmaLinux IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob 7.3 High -
perl-Module-LoadAlmaLinux Archive::Tar versions before 3.10 for Perl allow memory exhaustion via attacker controlled entry size field in tar header 7.5 High -
perl-Module-LoadAlmaLinux Archive::Tar versions before 3.08 for Perl extract symlinks with attacker controlled targets outside the extraction directory 9.1 Critical -
perl-Module-LoadAlmaLinux Perl threads have a working directory race condition where file operations may target unintended paths 5.9 Medium -
perl-Module-LoadAlmaLinux Perl: write past buffer end via illegal user-defined unicode property 7.0 High -
perl-Module-LoadAlmaLinux new module: perl:5.32 No score -
perl-Module-LoadAlmaLinux perl:5.30 bug fix and enhancement update No score -
perl-Module-LoadAlmaLinux new module: perl:5.30 No score -
perl-Module-LoadAlmaLinux perl:5.24 bug fix and enhancement update No score