python3-unbound vulnerabilities (AlmaLinux)
24 vulnerabilities.
-
python3-unboundAlmaLinux CNAME synthesis could lead to heap corruption 8.4 High -
python3-unboundAlmaLinux Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
python3-unboundAlmaLinux Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
python3-unboundAlmaLinux 'dns-error-reporting: yes' leads to stack buffer overflow 7.5 High -
python3-unboundAlmaLinux Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
python3-unboundAlmaLinux Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
python3-unboundAlmaLinux Unbounded name compression in certain cases causes degradation of service 6.9 Medium -
python3-unboundAlmaLinux Crash during DNSSEC validation of malicious content 8.7 High -
python3-unboundAlmaLinux Heap overflow with multiple NSID, COOKIE, PADDING EDNS options 8.7 High -
python3-unboundAlmaLinux Jostle logic bypass degrades resolution performance 6.9 Medium -
python3-unboundAlmaLinux Long list of incoming EDNS options degrades performance 6.6 Medium -
python3-unboundAlmaLinux Another 'ghost domain names' attack variant 6.6 Medium -
python3-unboundAlmaLinux Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
python3-unboundAlmaLinux Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
python3-unboundAlmaLinux Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
python3-unboundAlmaLinux Unbounded name compression could lead to Denial of Service 5.3 Medium -
python3-unboundAlmaLinux The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
python3-unboundAlmaLinux Unbound: unrestricted reconfiguration enabled to anyone that may lead to local privilege escalation 8.0 High -
python3-unboundAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
python3-unboundAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
python3-unboundAlmaLinux NRDelegation Attack 7.5 High -
python3-unboundAlmaLinux Novel "ghost domain names" attack by updating almost expired delegation information 6.5 Medium -
python3-unboundAlmaLinux Novel "ghost domain names" attack by introducing subdomain delegations 6.5 Medium -
python3-unboundAlmaLinux unbound bug fix and enhancement update No score