dnsmasq vulnerabilities (Alpaquita)
11 vulnerabilities.
dnsmasqAlpaquitaA flow has been identified into dnssec.c library, causing an infinite loop to dnsmasq service. An...4.4 MediumdnsmasqAlpaquitaDnsmasq: dnsmasq: out-of-bounds read in find_soa() due to missing extrabytes validation5.3 MediumdnsmasqAlpaquitaDnsmasq: dnsmasq: heap buffer overflow in log_query() when logging unsupported ds/dnskey replies5.9 MediumdnsmasqAlpaquitaCVE-2026-51727.3 HighdnsmasqAlpaquitaCVE-2026-48935.3 MediumdnsmasqAlpaquitaCVE-2026-48928.4 HighdnsmasqAlpaquitaCVE-2026-48915.3 MediumdnsmasqAlpaquitaCVE-2026-48907.5 HighdnsmasqAlpaquitaCVE-2026-22917.3 HighdnsmasqAlpaquitaThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 HighdnsmasqAlpaquitaCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 High