dnsmasq vulnerabilities (Alpine)
27 vulnerabilities.
-
dnsmasqAlpine CVE-2026-5172 7.3 High -
dnsmasqAlpine CVE-2026-4893 5.3 Medium -
dnsmasqAlpine CVE-2026-4892 8.4 High -
dnsmasqAlpine CVE-2026-4891 5.3 Medium -
dnsmasqAlpine CVE-2026-4890 7.5 High -
dnsmasqAlpine CVE-2026-2291 7.3 High -
dnsmasqAlpine The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
dnsmasqAlpine Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
dnsmasqAlpine An issue was discovered in Dnsmasq before 2.90. The default maximum EDNS.0 UDP packet size was... 7.5 High -
dnsmasqAlpine A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq. This flaw allows an... 7.5 High -
dnsmasqAlpine A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for... 4.0 Medium -
dnsmasqAlpine A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 5.9 Medium -
dnsmasqAlpine A flaw was found in dnsmasq before version 2.83. When receiving a query, dnsmasq does not check... 3.7 Low -
dnsmasqAlpine A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query,... 3.7 Low -
dnsmasqAlpine A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query,... 3.7 Low -
dnsmasqAlpine A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 5.9 Medium -
dnsmasqAlpine A flaw was found in dnsmasq before 2.83. A buffer overflow vulnerability was discovered in the... 8.1 High -
dnsmasqAlpine A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 8.1 High -
dnsmasqAlpine A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote... 3.7 Low -
dnsmasqAlpine A vulnerability was found in the implementation of DNSSEC in Dnsmasq up to and including 2.78.... 7.5 High -
dnsmasqAlpine Integer underflow in the add_pseudoheader function in dnsmasq before 2.78 , when the --add-mac, -... 7.5 High -
dnsmasqAlpine Memory leak in dnsmasq before 2.78, when the --add-mac, --add-cpe-id or --add-subnet option is... 7.5 High -
dnsmasqAlpine dnsmasq before 2.78, when configured as a relay, allows remote attackers to obtain sensitive... 5.9 Medium -
dnsmasqAlpine Stack-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasqAlpine Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasqAlpine Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasqAlpine In dnsmasq before 2.78, if the DNS packet size does not match the expected size, the size... 7.5 High