unbound vulnerabilities (Alpine)
44 vulnerabilities.
-
unboundAlpine CNAME synthesis could lead to heap corruption 8.4 High -
unboundAlpine Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
unboundAlpine Degradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration 5.9 Medium -
unboundAlpine Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name 4.8 Medium -
unboundAlpine 'dns-error-reporting: yes' leads to stack buffer overflow 7.5 High -
unboundAlpine 'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash 5.9 Medium -
unboundAlpine Privacy/configuration issue when adding local data in views through 'unbound-control' 3.1 Low -
unboundAlpine DNS Cookie bypass when combined with proxy-protocol use 3.7 Low -
unboundAlpine Memory corruption could lead to crash and denial of service 5.9 Medium -
unboundAlpine Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
unboundAlpine Attacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush 5.3 Medium -
unboundAlpine BOGUS configured primary hostname accepted for XFR in auth/rpz zones 6.5 Medium -
unboundAlpine 'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL 6.3 Medium -
unboundAlpine Possible heap use-after-free in an error path when a DoT forwarded query is jostled out 5.9 Medium -
unboundAlpine 'max-global-quota' reset by DNSSEC validation restarts 5.3 Medium -
unboundAlpine A wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path 3.7 Low -
unboundAlpine Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
unboundAlpine Off-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN 3.7 Low -
unboundAlpine Libunbound applications configured with 'unwanted-reply-threshold' could eventually be abruptly terminated 5.9 Medium -
unboundAlpine Extra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records 3.7 Low -
unboundAlpine Use after free and crash under special conditions in RPZ code 4.6 Medium -
unboundAlpine Unbounded name compression in certain cases causes degradation of service 6.9 Medium -
unboundAlpine Possible cache poisoning via promiscuous records for the authority section 5.7 Medium -
unboundAlpine Crash during DNSSEC validation of malicious content 8.7 High -
unboundAlpine Heap overflow with multiple NSID, COOKIE, PADDING EDNS options 8.7 High -
unboundAlpine Degradation of service with unbounded NSEC3 hash calculations 6.9 Medium -
unboundAlpine Jostle logic bypass degrades resolution performance 6.9 Medium -
unboundAlpine Long list of incoming EDNS options degrades performance 6.6 Medium -
unboundAlpine Another 'ghost domain names' attack variant 6.6 Medium -
unboundAlpine Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
unboundAlpine Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
unboundAlpine Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
unboundAlpine Unbounded name compression could lead to Denial of Service 5.3 Medium -
unboundAlpine The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
unboundAlpine Denial of service when trimming EDE text on positive replies 7.5 High -
unboundAlpine The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
unboundAlpine Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
unboundAlpine NRDelegation Attack 7.5 High -
unboundAlpine Novel "ghost domain names" attack by updating almost expired delegation information 6.5 Medium -
unboundAlpine Novel "ghost domain names" attack by introducing subdomain delegations 6.5 Medium -
unboundAlpine Unbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers. 7.5 High -
unboundAlpine Unbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an "NXNSAttack"... 7.5 High -
unboundAlpine Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code... 7.3 High -
unboundAlpine Unbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a... 7.5 High