knot-resolver vulnerabilities (Debian)
15 vulnerabilities.
-
knot-resolverDebian Knot Resolver before 6.4.1 allows remote code execution via a heap-based buffer overflow in the... 8.1 High -
knot-resolverDebian The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
knot-resolverDebian Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
knot-resolverDebian Knot Resolver before 5.7.0 performs many TCP reconnections upon receiving certain nonsensical... 7.5 High -
knot-resolverDebian Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification... 7.5 High -
knot-resolverDebian Knot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption)... 7.5 High -
knot-resolverDebian Knot Resolver through 5.5.1 may allow DNS cache poisoning when there is an attempt to limit... 5.3 Medium -
knot-resolverDebian Knot Resolver before 5.3.2 is prone to an assertion failure, triggerable by a remote attacker in... 7.5 High -
knot-resolverDebian A flaw was found in knot-resolver before version 2.3.0. Malformed DNS messages may cause denial... 7.5 High -
knot-resolverDebian Knot Resolver before 5.1.1 allows traffic amplification via a crafted DNS answer from an attacker... 7.5 High -
knot-resolverDebian knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU... 7.5 High -
knot-resolverDebian A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows... 6.3 Medium -
knot-resolverDebian A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0... 5.4 Medium -
knot-resolverDebian Improper input validation bug in DNS resolver component of Knot Resolver before 2.4.1 allows... 7.5 High -
knot-resolverDebian Improper input validation bugs in DNSSEC validators components in Knot Resolver (prior version 1... 3.7 Low