unbound vulnerabilities (Debian)
86 vulnerabilities.
unboundDebianCache poisoning via the ECS-enabled Rebirthday Attack8.7 HighunboundDebianUnbounded name compression could lead to Denial of Service5.3 MediumunboundDebianUnbound: heap-buffer-overflow in unbound4.8 MediumunboundDebianUnbound: null pointer dereference in unbound2.8 LowunboundDebianThe DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ...7.5 HighunboundDebianDenial of service when trimming EDE text on positive replies7.5 HighunboundDebianThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 HighunboundDebianCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 HighunboundDebianNRDelegation Attack7.5 HighunboundDebianNovel "ghost domain names" attack by updating almost expired delegation information6.5 MediumunboundDebianNovel "ghost domain names" attack by introducing subdomain delegations6.5 MediumunboundDebianUnbound before 1.9.5 allows configuration injection in create_unbound_ad_servers.sh upon a...5.9 MediumunboundDebianUnbound before 1.9.5 allows an integer overflow in the regional allocator via regional_alloc.9.8 CriticalunboundDebianUnbound before 1.9.5 allows an integer overflow in the regional allocator via the ALIGN_UP macro.9.8 CriticalunboundDebianUnbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an...9.8 CriticalunboundDebianUnbound before 1.9.5 allows an out-of-bounds write in sldns_bget_token_par.9.8 CriticalunboundDebianUnbound before 1.9.5 allows an assertion failure and denial of service in synth_cname.7.5 HighunboundDebianUnbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an...7.5 HighunboundDebianUnbound before 1.9.5 allows an integer overflow in a size calculation in dnscrypt/dnscrypt.c.9.8 CriticalunboundDebianUnbound before 1.9.5 allows an integer overflow in a size calculation in respip/respip.c.9.8 CriticalunboundDebianUnbound before 1.9.5 allows an infinite loop via a compressed name in dname_pkt_copy.7.5 HighunboundDebianUnbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy.7.5 HighunboundDebianUnbound before 1.9.5 allows an out-of-bounds write via a compressed name in rdata_copy.9.8 CriticalunboundDebianLocal symlink attack in Unbound and NSD5.5 MediumunboundDebianUnbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers.7.5 HighunboundDebianUnbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an "NXNSAttack"...7.5 HighunboundDebianUnbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code...7.3 HighunboundDebianUnbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a...7.5 HighunboundDebianA flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An...5.3 MediumunboundDebianiterator.c in NLnet Labs Unbound before 1.5.1 does not limit delegation chaining, which allows...4.3 MediumunboundDebianvalidator/val_nsec3.c in Unbound before 1.4.13p2 does not properly perform proof processing for...7.8 HighunboundDebianUnbound before 1.4.13p2 attempts to free unallocated memory during processing of duplicate CNAME...5.0 MediumunboundDebiandaemon/worker.c in Unbound 1.x before 1.4.10, when debugging functionality and the interface...4.3 MediumunboundDebianUnbound before 1.4.4 does not send responses for signed zones after mishandling an unspecified...5.0 MediumunboundDebianUnbound before 1.4.3 does not properly align structures on 64-bit platforms, which allows remote...5.0 MediumunboundDebianUnbound before 1.3.4 does not properly verify signatures for NSEC3 records, which allows remote...7.5 High