unbound vulnerabilities (Mageia)
56 vulnerabilities.
-
unboundMageia DNS-over-QUIC (DoQ) path-migration can lead to use-after-free on multi-threaded deployments. 7.5 High -
unboundMageia Aggregate DNS name chained pointer decompression work leads to degradation of service. 5.3 Medium -
unboundMageia Possible insecure NXDOMAIN for non-existing records under a configured island trust anchor underneath an insecure parent. 6.5 Medium -
unboundMageia Bypass of a configured island trust anchor underneath an insecure parent from an atacker-controlled NSEC record. 3.7 Low -
unboundMageia Possible cache poisoning vulnerability via a cache side-channel exposed by 'unwanted-reply-threshold' 5.3 Medium -
unboundMageia Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC 5.3 Medium -
unboundMageia Use-after-free in DoH stream cleanup code path 5.9 Medium -
unboundMageia CNAME synthesis could lead to heap corruption 8.4 High -
unboundMageia Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
unboundMageia Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
unboundMageia Possible degradation of service from continuous queries on the same TCP/DoT connection 5.3 Medium -
unboundMageia Use-after-free in DoQ stream output buffer on reset re-transmission 6.5 Medium -
unboundMageia Possible ZONEMD verification bypass window 4.4 Medium -
unboundMageia 'serve-expired' can bypass Unbound 'wait-limit' 3.7 Low -
unboundMageia Degradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration 5.9 Medium -
unboundMageia Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name 4.8 Medium -
unboundMageia Remote DNS-over-QUIC (DoQ) flow-control assertion failure in libngtcp2 5.9 Medium -
unboundMageia Packet of death for a DNSCrypt misconfigured Unbound 5.9 Medium -
unboundMageia 'dns-error-reporting: yes' leads to stack buffer overflow 7.5 High -
unboundMageia 'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash 5.9 Medium -
unboundMageia Privacy/configuration issue when adding local data in views through 'unbound-control' 3.1 Low -
unboundMageia DNS Cookie bypass when combined with proxy-protocol use 3.7 Low -
unboundMageia Memory corruption could lead to crash and denial of service 5.9 Medium -
unboundMageia Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
unboundMageia Attacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush 5.3 Medium -
unboundMageia BOGUS configured primary hostname accepted for XFR in auth/rpz zones 6.5 Medium -
unboundMageia 'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL 6.3 Medium -
unboundMageia Possible heap use-after-free in an error path when a DoT forwarded query is jostled out 5.9 Medium -
unboundMageia 'max-global-quota' reset by DNSSEC validation restarts 5.3 Medium -
unboundMageia A wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path 3.7 Low -
unboundMageia Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
unboundMageia Off-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN 3.7 Low -
unboundMageia Libunbound applications configured with 'unwanted-reply-threshold' could eventually be abruptly terminated 5.9 Medium -
unboundMageia Extra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records 3.7 Low -
unboundMageia Degradation of resolution service from improperly accounted client-terminated DNS-over-QUIC queries 3.7 Low -
unboundMageia Packet of death for DNSCrypt over TCP 7.5 High -
unboundMageia Remote DNS-over-QUIC denial of service due to `quic-size` budget bypass 7.5 High -
unboundMageia Assertion in libngtcp2 when under pressure in high concurrency DNS-over-QUIC environments 5.9 Medium -
unboundMageia Another 'ghost domain names' attack variant 6.6 Medium -
unboundMageia Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
unboundMageia Unbounded name compression could lead to Denial of Service 5.3 Medium -
unboundMageia Unbound: null pointer dereference in unbound 2.8 Low -
unboundMageia The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
unboundMageia The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
unboundMageia Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
unboundMageia NRDelegation Attack 7.5 High -
unboundMageia Novel "ghost domain names" attack by updating almost expired delegation information 6.5 Medium -
unboundMageia Novel "ghost domain names" attack by introducing subdomain delegations 6.5 Medium -
unboundMageia Local symlink attack in Unbound and NSD 5.5 Medium -
unboundMageia Unbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers. 7.5 High - Show olderLoading…