dhcp vulnerabilities (Red Hat)
29 vulnerabilities.
-
dhcpRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
dhcpRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
dhcpRed Hat Parsing large DNS messages may cause excessive CPU load 7.5 High -
dhcpRed Hat An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
dhcpRed Hat DHCP memory leak 6.5 Medium -
dhcpRed Hat An option refcount overflow exists in dhcpd 6.5 Medium -
dhcpRed Hat Processing large delegations may severely degrade resolver performance 5.3 Medium -
dhcpRed Hat DNS forwarders - cache poisoning vulnerability 6.8 Medium -
dhcpRed Hat It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests... 7.8 High -
dhcpRed Hat A buffer overrun in lease file parsing code can be used to exploit a common vulnerability shared by dhcpd and dhclient 7.4 High -
dhcpRed Hat dhcpd: use-after-free error leads crash in IPv6 mode when using mismatched BIND libraries 6.5 Medium -
dhcpRed Hat DHCP packages in Red Hat Enterprise Linux 6 and 7, Fedora 28, and earlier are vulnerable to a... 7.5 High -
dhcpRed Hat A malicious client can overflow a reference counter in ISC dhcpd 5.9 Medium -
dhcpRed Hat A specially constructed response from a malicious server can cause a buffer overflow in dhclient 7.5 High -
dhcpRed Hat Failure to properly clean up closed OMAPI connections can exhaust available sockets 5.3 Medium -
dhcpRed Hat ISC DHCP 4.1.x before 4.1-ESV-R13 and 4.2.x and 4.3.x before 4.3.4 does not restrict the number... 5.9 Medium -
dhcpRed Hat ISC DHCP 4.1.x before 4.1-ESV-R7 and 4.2.x before 4.2.4-P2 allows remote attackers to cause a... 7.1 High -
dhcpRed Hat Multiple memory leaks in ISC DHCP 4.1.x and 4.2.x before 4.2.4-P1 and 4.1-ESV before 4.1-ESV-R6... 3.3 Low -
dhcpRed Hat ISC DHCP 4.1.2 through 4.2.4 and 4.1-ESV before 4.1-ESV-R6 allows remote attackers to cause a... 6.1 Medium -
dhcpRed Hat dhcpd in ISC DHCP 4.x before 4.2.3-P1 and 4.1-ESV before 4.1-ESV-R4 does not properly handle... 5.0 Medium -
dhcpRed Hat The server in ISC DHCP 3.x and 4.x before 4.2.2, 3.1-ESV before 3.1-ESV-R3, and 4.1-ESV before 4... 7.8 High -
dhcpRed Hat The server in ISC DHCP 3.x and 4.x before 4.2.2, 3.1-ESV before 3.1-ESV-R3, and 4.1-ESV before 4... 7.8 High -
dhcpRed Hat dhclient in ISC DHCP 3.0.x through 4.2.x before 4.2.1-P1, 3.1-ESV before 3.1-ESV-R1, and 4.1-ESV... 7.5 High -
dhcpRed Hat The DHCPv6 server in ISC DHCP 4.0.x and 4.1.x before 4.1.2-P1, 4.0-ESV and 4.1-ESV before 4.1-ESV... 7.8 High -
dhcpRed Hat ISC DHCP server 4.0 before 4.0.2, 4.1 before 4.1.2, and 4.2 before 4.2.0-P1 allows remote... 4.3 Medium -
dhcpRed Hat The configtest function in the Red Hat dhcpd init script for DHCP 3.0.1 in Red Hat Enterprise... 6.9 Medium -
dhcpRed Hat Stack-based buffer overflow in the script_write_params method in client/dhclient.c in ISC DHCP... 10.0 High -
dhcpRed Hat Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD 4.0... 7.2 High -
dhcpRed Hat Integer underflow in the DHCP server in EMC VMware Workstation before 5.5.5 Build 56455 and 6.x... 10.0 High