dnsmasq-debuginfo vulnerabilities (Red Hat)
30 vulnerabilities.
-
dnsmasq-debuginfoRed Hat CVE-2026-5172 7.3 High -
dnsmasq-debuginfoRed Hat CVE-2026-4893 5.3 Medium -
dnsmasq-debuginfoRed Hat CVE-2026-4892 8.4 High -
dnsmasq-debuginfoRed Hat CVE-2026-4891 5.3 Medium -
dnsmasq-debuginfoRed Hat CVE-2026-4890 7.5 High -
dnsmasq-debuginfoRed Hat CVE-2026-2291 7.3 High -
dnsmasq-debuginfoRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
dnsmasq-debuginfoRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
dnsmasq-debuginfoRed Hat An issue was discovered in Dnsmasq before 2.90. The default maximum EDNS.0 UDP packet size was... 7.5 High -
dnsmasq-debuginfoRed Hat A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq. This flaw allows an... 7.5 High -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for... 4.0 Medium -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 5.9 Medium -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before version 2.83. When receiving a query, dnsmasq does not check... 3.7 Low -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query,... 3.7 Low -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query,... 3.7 Low -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 5.9 Medium -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before 2.83. A buffer overflow vulnerability was discovered in the... 8.1 High -
dnsmasq-debuginfoRed Hat A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 8.1 High -
dnsmasq-debuginfoRed Hat A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote... 3.7 Low -
dnsmasq-debuginfoRed Hat Improper bounds checking in Dnsmasq before 2.76 allows an attacker controlled DNS server to send... 7.5 High -
dnsmasq-debuginfoRed Hat Integer underflow in the add_pseudoheader function in dnsmasq before 2.78 , when the --add-mac, -... 7.5 High -
dnsmasq-debuginfoRed Hat Memory leak in dnsmasq before 2.78, when the --add-mac, --add-cpe-id or --add-subnet option is... 7.5 High -
dnsmasq-debuginfoRed Hat dnsmasq before 2.78, when configured as a relay, allows remote attackers to obtain sensitive... 5.9 Medium -
dnsmasq-debuginfoRed Hat Stack-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasq-debuginfoRed Hat Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasq-debuginfoRed Hat Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasq-debuginfoRed Hat Dnsmasq before 2.63test1, when used with certain libvirt configurations, replies to requests from... 5.0 Medium -
dnsmasq-debuginfoRed Hat The tftp_request function in tftp.c in dnsmasq before 2.50, when --enable-tftp is used, allows... 4.3 Medium -
dnsmasq-debuginfoRed Hat Heap-based buffer overflow in the tftp_request function in tftp.c in dnsmasq before 2.50, when -... 6.8 Medium -
dnsmasq-debuginfoRed Hat The DNS protocol, as implemented in (1) BIND 8 and 9 before 9.5.0-P1, 9.4.2-P1, and 9.3.5-P1; (2)... 6.8 Medium