perl-ExtUtils-Install vulnerabilities (Red Hat)
11 vulnerabilities.
-
perl-ExtUtils-InstallRed Hat Perl versions before 5.40.5-RC1, from 5.41.0 before 5.42.3-RC1, from 5.43.0 before 5.43.10 produce silently incorrect regular expression matches when an alternation of more than 65535 fixed string bra… 9.1 Critical -
perl-ExtUtils-InstallRed Hat IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob 7.3 High -
perl-ExtUtils-InstallRed Hat Archive::Tar versions before 3.10 for Perl allow memory exhaustion via attacker controlled entry size field in tar header 7.5 High -
perl-ExtUtils-InstallRed Hat Archive::Tar versions before 3.08 for Perl extract symlinks with attacker controlled targets outside the extraction directory 9.1 Critical -
perl-ExtUtils-InstallRed Hat Perl threads have a working directory race condition where file operations may target unintended paths 5.9 Medium -
perl-ExtUtils-InstallRed Hat Perl: write past buffer end via illegal user-defined unicode property 7.0 High -
perl-ExtUtils-InstallRed Hat CPAN.pm before 2.35 does not verify TLS certificates when downloading distributions over HTTPS. 8.1 High -
perl-ExtUtils-InstallRed Hat CVE-2020-12723 does not affect BellSoft software 7.5 High -
perl-ExtUtils-InstallRed Hat CVE-2020-10878 does not affect BellSoft software 8.6 High -
perl-ExtUtils-InstallRed Hat CVE-2020-10543 does not affect BellSoft software 8.2 High -
perl-ExtUtils-InstallRed Hat Perl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a crafted regular... 9.8 Critical