python3-unbound vulnerabilities (Red Hat)
68 vulnerabilities.
-
python3-unboundRed Hat Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC 5.3 Medium -
python3-unboundRed Hat Use-after-free in DoH stream cleanup code path 5.9 Medium -
python3-unboundRed Hat CNAME synthesis could lead to heap corruption 8.4 High -
python3-unboundRed Hat Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
python3-unboundRed Hat Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
python3-unboundRed Hat Possible degradation of service from continuous queries on the same TCP/DoT connection 5.3 Medium -
python3-unboundRed Hat Use-after-free in DoQ stream output buffer on reset re-transmission 6.5 Medium -
python3-unboundRed Hat Possible ZONEMD verification bypass window 4.4 Medium -
python3-unboundRed Hat 'serve-expired' can bypass Unbound 'wait-limit' 3.7 Low -
python3-unboundRed Hat Degradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration 5.9 Medium -
python3-unboundRed Hat Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name 4.8 Medium -
python3-unboundRed Hat Remote DNS-over-QUIC (DoQ) flow-control assertion failure in libngtcp2 5.9 Medium -
python3-unboundRed Hat Packet of death for a DNSCrypt misconfigured Unbound 5.9 Medium -
python3-unboundRed Hat 'dns-error-reporting: yes' leads to stack buffer overflow 7.5 High -
python3-unboundRed Hat 'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash 5.9 Medium -
python3-unboundRed Hat Privacy/configuration issue when adding local data in views through 'unbound-control' 3.1 Low -
python3-unboundRed Hat DNS Cookie bypass when combined with proxy-protocol use 3.7 Low -
python3-unboundRed Hat Memory corruption could lead to crash and denial of service 5.9 Medium -
python3-unboundRed Hat Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
python3-unboundRed Hat Attacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush 5.3 Medium -
python3-unboundRed Hat BOGUS configured primary hostname accepted for XFR in auth/rpz zones 6.5 Medium -
python3-unboundRed Hat 'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL 6.3 Medium -
python3-unboundRed Hat Possible heap use-after-free in an error path when a DoT forwarded query is jostled out 5.9 Medium -
python3-unboundRed Hat 'max-global-quota' reset by DNSSEC validation restarts 5.3 Medium -
python3-unboundRed Hat A wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path 3.7 Low -
python3-unboundRed Hat Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
python3-unboundRed Hat Off-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN 3.7 Low -
python3-unboundRed Hat Extra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records 3.7 Low -
python3-unboundRed Hat Degradation of resolution service from improperly accounted client-terminated DNS-over-QUIC queries 3.7 Low -
python3-unboundRed Hat Packet of death for DNSCrypt over TCP 7.5 High -
python3-unboundRed Hat Remote DNS-over-QUIC denial of service due to `quic-size` budget bypass 7.5 High -
python3-unboundRed Hat Assertion in libngtcp2 when under pressure in high concurrency DNS-over-QUIC environments 5.9 Medium -
python3-unboundRed Hat Use after free and crash under special conditions in RPZ code 4.6 Medium -
python3-unboundRed Hat Unbounded name compression in certain cases causes degradation of service 6.9 Medium -
python3-unboundRed Hat Possible cache poisoning via promiscuous records for the authority section 5.7 Medium -
python3-unboundRed Hat Crash during DNSSEC validation of malicious content 8.7 High -
python3-unboundRed Hat Heap overflow with multiple NSID, COOKIE, PADDING EDNS options 8.7 High -
python3-unboundRed Hat Degradation of service with unbounded NSEC3 hash calculations 6.9 Medium -
python3-unboundRed Hat Jostle logic bypass degrades resolution performance 6.9 Medium -
python3-unboundRed Hat Long list of incoming EDNS options degrades performance 6.6 Medium -
python3-unboundRed Hat Another 'ghost domain names' attack variant 6.6 Medium -
python3-unboundRed Hat Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
python3-unboundRed Hat Packet of death with DNSCrypt 4.6 Medium -
python3-unboundRed Hat Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
python3-unboundRed Hat Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
python3-unboundRed Hat Unbounded name compression could lead to Denial of Service 5.3 Medium -
python3-unboundRed Hat The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
python3-unboundRed Hat Unbound: unrestricted reconfiguration enabled to anyone that may lead to local privilege escalation 8.0 High -
python3-unboundRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
python3-unboundRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High - Show olderLoading…