python3-unbound-debuginfo vulnerabilities (Red Hat)
38 vulnerabilities.
-
python3-unbound-debuginfoRed Hat CNAME synthesis could lead to heap corruption 8.4 High -
python3-unbound-debuginfoRed Hat Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
python3-unbound-debuginfoRed Hat Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
python3-unbound-debuginfoRed Hat 'dns-error-reporting: yes' leads to stack buffer overflow 7.5 High -
python3-unbound-debuginfoRed Hat Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
python3-unbound-debuginfoRed Hat Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
python3-unbound-debuginfoRed Hat Unbounded name compression in certain cases causes degradation of service 6.9 Medium -
python3-unbound-debuginfoRed Hat Crash during DNSSEC validation of malicious content 8.7 High -
python3-unbound-debuginfoRed Hat Heap overflow with multiple NSID, COOKIE, PADDING EDNS options 8.7 High -
python3-unbound-debuginfoRed Hat Jostle logic bypass degrades resolution performance 6.9 Medium -
python3-unbound-debuginfoRed Hat Long list of incoming EDNS options degrades performance 6.6 Medium -
python3-unbound-debuginfoRed Hat Another 'ghost domain names' attack variant 6.6 Medium -
python3-unbound-debuginfoRed Hat Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
python3-unbound-debuginfoRed Hat Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
python3-unbound-debuginfoRed Hat Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
python3-unbound-debuginfoRed Hat Unbounded name compression could lead to Denial of Service 5.3 Medium -
python3-unbound-debuginfoRed Hat The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
python3-unbound-debuginfoRed Hat Unbound: unrestricted reconfiguration enabled to anyone that may lead to local privilege escalation 8.0 High -
python3-unbound-debuginfoRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
python3-unbound-debuginfoRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
python3-unbound-debuginfoRed Hat NRDelegation Attack 7.5 High -
python3-unbound-debuginfoRed Hat Novel "ghost domain names" attack by updating almost expired delegation information 6.5 Medium -
python3-unbound-debuginfoRed Hat Novel "ghost domain names" attack by introducing subdomain delegations 6.5 Medium -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an integer overflow in the regional allocator via regional_alloc. 9.8 Critical -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an integer overflow in the regional allocator via the ALIGN_UP macro. 9.8 Critical -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an... 9.8 Critical -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an out-of-bounds write in sldns_bget_token_par. 9.8 Critical -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an assertion failure and denial of service in synth_cname. 7.5 High -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an... 7.5 High -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an integer overflow in a size calculation in dnscrypt/dnscrypt.c. 9.8 Critical -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an integer overflow in a size calculation in respip/respip.c. 9.8 Critical -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an infinite loop via a compressed name in dname_pkt_copy. 7.5 High -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy. 7.5 High -
python3-unbound-debuginfoRed Hat Unbound before 1.9.5 allows an out-of-bounds write via a compressed name in rdata_copy. 9.8 Critical -
python3-unbound-debuginfoRed Hat Local symlink attack in Unbound and NSD 5.5 Medium -
python3-unbound-debuginfoRed Hat Unbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers. 7.5 High -
python3-unbound-debuginfoRed Hat Unbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an "NXNSAttack"... 7.5 High -
python3-unbound-debuginfoRed Hat Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code... 7.3 High