libspf2 vulnerabilities (SUSE)
31 vulnerabilities.
-
libspf2SUSE Stack buffer overflow in libspf2 versions below 1.2.11 when processing certain SPF macros can... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 allows an off-by-two Out-of-bounds Write because "-F ''" is mishandled by... 7.8 High -
libspf2SUSE Exim 4 before 4.92 allows Integer Overflow to Buffer Overflow, in which an unauthenticated remote... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkim_finish_bodyhash does not validate... 7.5 High -
libspf2SUSE Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 allows Out-of-bounds Read. smtp_setup_msg may disclose sensitive information... 7.5 High -
libspf2SUSE Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP... 8.8 High -
libspf2SUSE Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack... 7.5 High -
libspf2SUSE Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e... 9.8 Critical -
libspf2SUSE Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. The -oP option is available to... 6.1 Medium -
libspf2SUSE Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root,... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow because get_stdinput allows... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root... 7.8 High -
libspf2SUSE Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root... 7.8 High -
libspf2SUSE Exim through 4.93 has an out-of-bounds read in the SPA authenticator that could result in SPA... 7.5 High -
libspf2SUSE Local privilege escalation in exim package from user mail to root 8.4 High -
libspf2SUSE Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019... 9.8 Critical -
libspf2SUSE Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing... 9.8 Critical -
libspf2SUSE Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual... 9.8 Critical -
libspf2SUSE A flaw was found in Exim versions 4.87 to 4.91 (inclusive). Improper validation of recipient... 9.0 Critical -
libspf2SUSE An issue was discovered in the base64d function in the SMTP listener in Exim before 4.90.1. By... 9.8 Critical -
libspf2SUSE The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote... 7.5 High -
libspf2SUSE The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote... 9.8 Critical -
libspf2SUSE Exim supports the use of multiple "-p" command line arguments which are malloc()'ed and never... 4.0 Medium