unbound vulnerabilities (SUSE)
71 vulnerabilities.
unboundSUSEThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 HighunboundSUSECertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 HighunboundSUSENRDelegation Attack7.5 HighunboundSUSENovel "ghost domain names" attack by updating almost expired delegation information6.5 MediumunboundSUSENovel "ghost domain names" attack by introducing subdomain delegations6.5 MediumunboundSUSEUnbound before 1.9.5 allows configuration injection in create_unbound_ad_servers.sh upon a...5.9 MediumunboundSUSEUnbound before 1.9.5 allows an integer overflow in the regional allocator via regional_alloc.9.8 CriticalunboundSUSEUnbound before 1.9.5 allows an integer overflow in the regional allocator via the ALIGN_UP macro.9.8 CriticalunboundSUSEUnbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an...9.8 CriticalunboundSUSEUnbound before 1.9.5 allows an out-of-bounds write in sldns_bget_token_par.9.8 CriticalunboundSUSEUnbound before 1.9.5 allows an assertion failure and denial of service in synth_cname.7.5 HighunboundSUSEUnbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an...7.5 HighunboundSUSEUnbound before 1.9.5 allows an integer overflow in a size calculation in dnscrypt/dnscrypt.c.9.8 CriticalunboundSUSEUnbound before 1.9.5 allows an integer overflow in a size calculation in respip/respip.c.9.8 CriticalunboundSUSEUnbound before 1.9.5 allows an infinite loop via a compressed name in dname_pkt_copy.7.5 HighunboundSUSEUnbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy.7.5 HighunboundSUSEUnbound before 1.9.5 allows an out-of-bounds write via a compressed name in rdata_copy.9.8 CriticalunboundSUSELocal symlink attack in Unbound and NSD5.5 MediumunboundSUSEUnbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers.7.5 HighunboundSUSEUnbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an "NXNSAttack"...7.5 HighunboundSUSEUnbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code...7.3 High