dnsmasq vulnerabilities (TuxCare)
10 vulnerabilities.
-
dnsmasqTuxCare Dnsmasq: dnsmasq: heap buffer overflow in log_query() when logging unsupported ds/dnskey replies 5.9 Medium -
dnsmasqTuxCare CVE-2026-4893 5.3 Medium -
dnsmasqTuxCare CVE-2026-4892 8.4 High -
dnsmasqTuxCare CVE-2026-4891 5.3 Medium -
dnsmasqTuxCare CVE-2026-4890 7.5 High -
dnsmasqTuxCare CVE-2026-2291 7.3 High -
dnsmasqTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
dnsmasqTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
dnsmasqTuxCare An issue was discovered in Dnsmasq before 2.90. The default maximum EDNS.0 UDP packet size was... 7.5 High -
dnsmasqTuxCare A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq. This flaw allows an... 7.5 High