python3-unbound vulnerabilities (TuxCare)
40 vulnerabilities.
-
python3-unboundTuxCare Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC 5.3 Medium -
python3-unboundTuxCare Use-after-free in DoH stream cleanup code path 5.9 Medium -
python3-unboundTuxCare Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
python3-unboundTuxCare Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
python3-unboundTuxCare Possible degradation of service from continuous queries on the same TCP/DoT connection 5.3 Medium -
python3-unboundTuxCare Possible ZONEMD verification bypass window 4.4 Medium -
python3-unboundTuxCare Degradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration 5.9 Medium -
python3-unboundTuxCare Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name 4.8 Medium -
python3-unboundTuxCare Packet of death for a DNSCrypt misconfigured Unbound 5.9 Medium -
python3-unboundTuxCare 'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash 5.9 Medium -
python3-unboundTuxCare Privacy/configuration issue when adding local data in views through 'unbound-control' 3.1 Low -
python3-unboundTuxCare Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
python3-unboundTuxCare Attacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush 5.3 Medium -
python3-unboundTuxCare BOGUS configured primary hostname accepted for XFR in auth/rpz zones 6.5 Medium -
python3-unboundTuxCare 'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL 6.3 Medium -
python3-unboundTuxCare Possible heap use-after-free in an error path when a DoT forwarded query is jostled out 5.9 Medium -
python3-unboundTuxCare A wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path 3.7 Low -
python3-unboundTuxCare Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
python3-unboundTuxCare Off-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN 3.7 Low -
python3-unboundTuxCare Libunbound applications configured with 'unwanted-reply-threshold' could eventually be abruptly terminated 5.9 Medium -
python3-unboundTuxCare Extra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records 3.7 Low -
python3-unboundTuxCare Packet of death for DNSCrypt over TCP 7.5 High -
python3-unboundTuxCare Use after free and crash under special conditions in RPZ code 4.6 Medium -
python3-unboundTuxCare Possible cache poisoning via promiscuous records for the authority section 5.7 Medium -
python3-unboundTuxCare Crash during DNSSEC validation of malicious content 8.7 High -
python3-unboundTuxCare Heap overflow with multiple NSID, COOKIE, PADDING EDNS options 8.7 High -
python3-unboundTuxCare Degradation of service with unbounded NSEC3 hash calculations 6.9 Medium -
python3-unboundTuxCare Jostle logic bypass degrades resolution performance 6.9 Medium -
python3-unboundTuxCare Long list of incoming EDNS options degrades performance 6.6 Medium -
python3-unboundTuxCare Another 'ghost domain names' attack variant 6.6 Medium -
python3-unboundTuxCare Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
python3-unboundTuxCare Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
python3-unboundTuxCare Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
python3-unboundTuxCare Unbounded name compression could lead to Denial of Service 5.3 Medium -
python3-unboundTuxCare Unbound: heap-buffer-overflow in unbound 4.8 Medium -
python3-unboundTuxCare Unbound: null pointer dereference in unbound 2.8 Low -
python3-unboundTuxCare The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
python3-unboundTuxCare Unbound: unrestricted reconfiguration enabled to anyone that may lead to local privilege escalation 8.0 High -
python3-unboundTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
python3-unboundTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High