unbound-devel vulnerabilities (TuxCare)
49 vulnerabilities.
unbound-develTuxCareAggregate DNS name chained pointer decompression work leads to degradation of service.5.3 Mediumunbound-develTuxCarePossible insecure NXDOMAIN for non-existing records under a configured island trust anchor underneath an insecure parent.6.5 Mediumunbound-develTuxCareBypass of a configured island trust anchor underneath an insecure parent from an atacker-controlled NSEC record.3.7 Lowunbound-develTuxCarePossible cache poisoning vulnerability via a cache side-channel exposed by 'unwanted-reply-threshold'5.3 Mediumunbound-develTuxCareUpdate of unboundNo scoreunbound-develTuxCareUpdate of unboundNo scoreunbound-develTuxCareUpdate of unboundNo scoreunbound-develTuxCareRetrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC5.3 Mediumunbound-develTuxCareUse-after-free in DoH stream cleanup code path5.9 Mediumunbound-develTuxCareCNAME synthesis could lead to heap corruption8.4 Highunbound-develTuxCareHeap buffer overflow and possible Remote Code Execution when digesting DNSKEY9.1 Criticalunbound-develTuxCarePossible heap buffer overflow during DNSSEC canonicalization7.5 Highunbound-develTuxCarePossible degradation of service from continuous queries on the same TCP/DoT connection5.3 Mediumunbound-develTuxCarePossible ZONEMD verification bypass window4.4 Mediumunbound-develTuxCareDegradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration5.9 Mediumunbound-develTuxCarePossible heap buffer overflow when validator canonicalizes RDATA that contains domain name4.8 Mediumunbound-develTuxCarePacket of death for a DNSCrypt misconfigured Unbound5.9 Mediumunbound-develTuxCare'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash5.9 Mediumunbound-develTuxCarePrivacy/configuration issue when adding local data in views through 'unbound-control'3.1 Lowunbound-develTuxCarePossible cache poisoning attack by mapping source port population per thread5.7 Mediumunbound-develTuxCareAttacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush5.3 Mediumunbound-develTuxCareBOGUS configured primary hostname accepted for XFR in auth/rpz zones6.5 Mediumunbound-develTuxCare'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL6.3 Mediumunbound-develTuxCarePossible heap use-after-free in an error path when a DoT forwarded query is jostled out5.9 Mediumunbound-develTuxCareA wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path3.7 Lowunbound-develTuxCareCross-zone wildcard cache poisoning via RRSIG.labels manipulation7.5 Highunbound-develTuxCareOff-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN3.7 Lowunbound-develTuxCareLibunbound applications configured with 'unwanted-reply-threshold' could eventually be abruptly terminated5.9 Mediumunbound-develTuxCareExtra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records3.7 Lowunbound-develTuxCarePacket of death for DNSCrypt over TCP7.5 Highunbound-develTuxCareUse after free and crash under special conditions in RPZ code4.6 Mediumunbound-develTuxCarePossible cache poisoning via promiscuous records for the authority section5.7 Mediumunbound-develTuxCareCrash during DNSSEC validation of malicious content8.7 Highunbound-develTuxCareHeap overflow with multiple NSID, COOKIE, PADDING EDNS options8.7 Highunbound-develTuxCareDegradation of service with unbounded NSEC3 hash calculations6.9 Mediumunbound-develTuxCareJostle logic bypass degrades resolution performance6.9 Mediumunbound-develTuxCareLong list of incoming EDNS options degrades performance6.6 Mediumunbound-develTuxCareAnother 'ghost domain names' attack variant6.6 Mediumunbound-develTuxCarePossible arbitrary code execution during DNSSEC validation9.1 Criticalunbound-develTuxCarePossible domain hijacking via promiscuous records in the authority section5.7 Mediumunbound-develTuxCareCache poisoning via the ECS-enabled Rebirthday Attack8.7 Highunbound-develTuxCareUnbounded name compression could lead to Denial of Service5.3 Mediumunbound-develTuxCareUnbound: heap-buffer-overflow in unbound4.8 Mediumunbound-develTuxCareUnbound: null pointer dereference in unbound2.8 Lowunbound-develTuxCareThe DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ...7.5 Highunbound-develTuxCareUnbound: unrestricted reconfiguration enabled to anyone that may lead to local privilege escalation8.0 Highunbound-develTuxCareThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 Highunbound-develTuxCareCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 Highunbound-develTuxCareNRDelegation Attack7.5 High