unbound-python vulnerabilities (TuxCare)
22 vulnerabilities.
-
unbound-pythonTuxCare Aggregate DNS name chained pointer decompression work leads to degradation of service. 5.3 Medium -
unbound-pythonTuxCare Possible insecure NXDOMAIN for non-existing records under a configured island trust anchor underneath an insecure parent. 6.5 Medium -
unbound-pythonTuxCare Bypass of a configured island trust anchor underneath an insecure parent from an atacker-controlled NSEC record. 3.7 Low -
unbound-pythonTuxCare Possible cache poisoning vulnerability via a cache side-channel exposed by 'unwanted-reply-threshold' 5.3 Medium -
unbound-pythonTuxCare Update of unbound No score -
unbound-pythonTuxCare Update of unbound No score -
unbound-pythonTuxCare Update of unbound No score -
unbound-pythonTuxCare Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC 5.3 Medium -
unbound-pythonTuxCare CNAME synthesis could lead to heap corruption 8.4 High -
unbound-pythonTuxCare Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
unbound-pythonTuxCare Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
unbound-pythonTuxCare Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
unbound-pythonTuxCare Possible cache poisoning via promiscuous records for the authority section 5.7 Medium -
unbound-pythonTuxCare Crash during DNSSEC validation of malicious content 8.7 High -
unbound-pythonTuxCare Long list of incoming EDNS options degrades performance 6.6 Medium -
unbound-pythonTuxCare Another 'ghost domain names' attack variant 6.6 Medium -
unbound-pythonTuxCare Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
unbound-pythonTuxCare Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
unbound-pythonTuxCare Unbounded name compression could lead to Denial of Service 5.3 Medium -
unbound-pythonTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
unbound-pythonTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
unbound-pythonTuxCare NRDelegation Attack 7.5 High