dnsmasq vulnerabilities (Ubuntu)
47 vulnerabilities.
-
dnsmasqUbuntu Dnsmasq: dnsmasq: heap out-of-bounds read in dhcpv6 option 39 fqdn decoder 4.3 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: --leasequery without address argument applies no source address check 4.3 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: tftp prefetch cache keyed on stale heap pointer serves wrong file content 6.8 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: tcp/53 child-slot exhaustion starves dnssec validation 5.3 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: heap out-of-bounds write in dnssec validator via to_wire/from_wire transforms 5.3 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: out-of-bailiwick cache injection through cname chase in split-dns configurations 6.8 Medium -
dnsmasqUbuntu A flow has been identified into dnssec.c library, causing an infinite loop to dnsmasq service. An... 4.4 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: out-of-bounds read in find_soa() due to missing extrabytes validation 5.3 Medium -
dnsmasqUbuntu Dnsmasq: dnsmasq: heap buffer overflow in log_query() when logging unsupported ds/dnskey replies 5.9 Medium -
dnsmasqUbuntu CVE-2026-5172 7.3 High -
dnsmasqUbuntu CVE-2026-4893 5.3 Medium -
dnsmasqUbuntu CVE-2026-4892 8.4 High -
dnsmasqUbuntu CVE-2026-4891 5.3 Medium -
dnsmasqUbuntu CVE-2026-4890 7.5 High -
dnsmasqUbuntu CVE-2026-2291 7.3 High -
dnsmasqUbuntu Dnsmasq: dnsmasq: denial of service due to out-of-bounds write in dhcp bootreply processing 7.5 High -
dnsmasqUbuntu dnsmasq-utils 2.79-1 - 'dhcp_release' Denial of Service 6.9 Medium -
dnsmasqUbuntu A vulnerability was determined in dnsmasq up to 2.73rc6. Affected by this issue is the function... 1.9 Low -
dnsmasqUbuntu A vulnerability was found in dnsmasq up to 2.73rc6. Affected by this vulnerability is the... 1.9 Low -
dnsmasqUbuntu A vulnerability has been found in dnsmasq up to 2.73rc6. Affected is the function parse_hex of... 7.1 High -
dnsmasqUbuntu dnsmasq 2.9 is vulnerable to Integer Overflow via forward_query. 7.5 High -
dnsmasqUbuntu The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
dnsmasqUbuntu Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
dnsmasqUbuntu An issue was discovered in Dnsmasq before 2.90. The default maximum EDNS.0 UDP packet size was... 7.5 High -
dnsmasqUbuntu A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq. This flaw allows an... 7.5 High -
dnsmasqUbuntu A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for... 4.0 Medium -
dnsmasqUbuntu dnsmasq regression No score -
dnsmasqUbuntu A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 5.9 Medium -
dnsmasqUbuntu A flaw was found in dnsmasq before version 2.83. When receiving a query, dnsmasq does not check... 3.7 Low -
dnsmasqUbuntu A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query,... 3.7 Low -
dnsmasqUbuntu A flaw was found in dnsmasq before version 2.83. When getting a reply from a forwarded query,... 3.7 Low -
dnsmasqUbuntu A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 5.9 Medium -
dnsmasqUbuntu A flaw was found in dnsmasq before 2.83. A buffer overflow vulnerability was discovered in the... 8.1 High -
dnsmasqUbuntu A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in... 8.1 High -
dnsmasqUbuntu A flaw was found in the default configuration of dnsmasq, as shipped with Fedora versions prior... 5.9 Medium -
dnsmasqUbuntu A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote... 3.7 Low -
dnsmasqUbuntu Improper bounds checking in Dnsmasq before 2.76 allows an attacker controlled DNS server to send... 7.5 High -
dnsmasqUbuntu dnsmasq update No score -
dnsmasqUbuntu A vulnerability was found in the implementation of DNSSEC in Dnsmasq up to and including 2.78.... 7.5 High -
dnsmasqUbuntu Integer underflow in the add_pseudoheader function in dnsmasq before 2.78 , when the --add-mac, -... 7.5 High -
dnsmasqUbuntu Memory leak in dnsmasq before 2.78, when the --add-mac, --add-cpe-id or --add-subnet option is... 7.5 High -
dnsmasqUbuntu dnsmasq before 2.78, when configured as a relay, allows remote attackers to obtain sensitive... 5.9 Medium -
dnsmasqUbuntu Stack-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasqUbuntu Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasqUbuntu Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of... 9.8 Critical -
dnsmasqUbuntu Dnsmasq before 2.76 allows remote servers to cause a denial of service (crash) via a reply with... 7.5 High -
dnsmasqUbuntu The tcp_request function in Dnsmasq before 2.73rc4 does not properly handle the return value of... 6.4 Medium