unbound vulnerabilities (Ubuntu)
78 vulnerabilities.
unboundUbuntuCache poisoning via the ECS-enabled Rebirthday Attack8.7 HighunboundUbuntuUnbounded name compression could lead to Denial of Service5.3 MediumunboundUbuntuUnbound: heap-buffer-overflow in unbound4.8 MediumunboundUbuntuUnbound: null pointer dereference in unbound2.8 LowunboundUbuntuThe DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ...7.5 HighunboundUbuntuDenial of service when trimming EDE text on positive replies7.5 HighunboundUbuntuThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 HighunboundUbuntuCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 HighunboundUbuntuNRDelegation Attack7.5 HighunboundUbuntuNovel "ghost domain names" attack by updating almost expired delegation information6.5 MediumunboundUbuntuNovel "ghost domain names" attack by introducing subdomain delegations6.5 MediumunboundUbuntuUnbound before 1.9.5 allows configuration injection in create_unbound_ad_servers.sh upon a...5.9 MediumunboundUbuntuUnbound before 1.9.5 allows an integer overflow in the regional allocator via regional_alloc.9.8 CriticalunboundUbuntuUnbound before 1.9.5 allows an integer overflow in the regional allocator via the ALIGN_UP macro.9.8 CriticalunboundUbuntuUnbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an...9.8 CriticalunboundUbuntuUnbound before 1.9.5 allows an out-of-bounds write in sldns_bget_token_par.9.8 CriticalunboundUbuntuUnbound before 1.9.5 allows an assertion failure and denial of service in synth_cname.7.5 HighunboundUbuntuUnbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an...7.5 HighunboundUbuntuUnbound before 1.9.5 allows an integer overflow in a size calculation in dnscrypt/dnscrypt.c.9.8 CriticalunboundUbuntuUnbound before 1.9.5 allows an integer overflow in a size calculation in respip/respip.c.9.8 CriticalunboundUbuntuUnbound before 1.9.5 allows an infinite loop via a compressed name in dname_pkt_copy.7.5 HighunboundUbuntuUnbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy.7.5 HighunboundUbuntuUnbound before 1.9.5 allows an out-of-bounds write via a compressed name in rdata_copy.9.8 CriticalunboundUbuntuLocal symlink attack in Unbound and NSD5.5 MediumunboundUbuntuUnbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers.7.5 HighunboundUbuntuUnbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an "NXNSAttack"...7.5 HighunboundUbuntuA flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An...5.3 MediumunboundUbuntuiterator.c in NLnet Labs Unbound before 1.5.1 does not limit delegation chaining, which allows...4.3 Medium