unbound vulnerabilities (openEuler)
53 vulnerabilities.
-
unboundopenEuler Aggregate DNS name chained pointer decompression work leads to degradation of service. 5.3 Medium -
unboundopenEuler Possible insecure NXDOMAIN for non-existing records under a configured island trust anchor underneath an insecure parent. 6.5 Medium -
unboundopenEuler Bypass of a configured island trust anchor underneath an insecure parent from an atacker-controlled NSEC record. 3.7 Low -
unboundopenEuler Possible cache poisoning vulnerability via a cache side-channel exposed by 'unwanted-reply-threshold' 5.3 Medium -
unboundopenEuler Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC 5.3 Medium -
unboundopenEuler Use-after-free in DoH stream cleanup code path 5.9 Medium -
unboundopenEuler CNAME synthesis could lead to heap corruption 8.4 High -
unboundopenEuler Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY 9.1 Critical -
unboundopenEuler Possible heap buffer overflow during DNSSEC canonicalization 7.5 High -
unboundopenEuler Possible degradation of service from continuous queries on the same TCP/DoT connection 5.3 Medium -
unboundopenEuler Possible ZONEMD verification bypass window 4.4 Medium -
unboundopenEuler 'serve-expired' can bypass Unbound 'wait-limit' 3.7 Low -
unboundopenEuler Degradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration 5.9 Medium -
unboundopenEuler Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name 4.8 Medium -
unboundopenEuler Packet of death for a DNSCrypt misconfigured Unbound 5.9 Medium -
unboundopenEuler 'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash 5.9 Medium -
unboundopenEuler Privacy/configuration issue when adding local data in views through 'unbound-control' 3.1 Low -
unboundopenEuler Possible cache poisoning attack by mapping source port population per thread 5.7 Medium -
unboundopenEuler Attacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush 5.3 Medium -
unboundopenEuler BOGUS configured primary hostname accepted for XFR in auth/rpz zones 6.5 Medium -
unboundopenEuler 'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL 6.3 Medium -
unboundopenEuler Possible heap use-after-free in an error path when a DoT forwarded query is jostled out 5.9 Medium -
unboundopenEuler A wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path 3.7 Low -
unboundopenEuler Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 7.5 High -
unboundopenEuler Off-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN 3.7 Low -
unboundopenEuler Libunbound applications configured with 'unwanted-reply-threshold' could eventually be abruptly terminated 5.9 Medium -
unboundopenEuler Extra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records 3.7 Low -
unboundopenEuler Packet of death for DNSCrypt over TCP 7.5 High -
unboundopenEuler Use after free and crash under special conditions in RPZ code 4.6 Medium -
unboundopenEuler Unbounded name compression in certain cases causes degradation of service 6.9 Medium -
unboundopenEuler Possible cache poisoning via promiscuous records for the authority section 5.7 Medium -
unboundopenEuler Crash during DNSSEC validation of malicious content 8.7 High -
unboundopenEuler Heap overflow with multiple NSID, COOKIE, PADDING EDNS options 8.7 High -
unboundopenEuler Degradation of service with unbounded NSEC3 hash calculations 6.9 Medium -
unboundopenEuler Jostle logic bypass degrades resolution performance 6.9 Medium -
unboundopenEuler Long list of incoming EDNS options degrades performance 6.6 Medium -
unboundopenEuler Another 'ghost domain names' attack variant 6.6 Medium -
unboundopenEuler Possible arbitrary code execution during DNSSEC validation 9.1 Critical -
unboundopenEuler Packet of death with DNSCrypt 4.6 Medium -
unboundopenEuler Possible domain hijacking via promiscuous records in the authority section 5.7 Medium -
unboundopenEuler Cache poisoning via the ECS-enabled Rebirthday Attack 8.7 High -
unboundopenEuler Unbounded name compression could lead to Denial of Service 5.3 Medium -
unboundopenEuler Unbound: heap-buffer-overflow in unbound 4.8 Medium -
unboundopenEuler Unbound: null pointer dereference in unbound 2.8 Low -
unboundopenEuler The DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ... 7.5 High -
unboundopenEuler Unbound: unrestricted reconfiguration enabled to anyone that may lead to local privilege escalation 8.0 High -
unboundopenEuler The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
unboundopenEuler Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
unboundopenEuler NRDelegation Attack 7.5 High -
unboundopenEuler Novel "ghost domain names" attack by updating almost expired delegation information 6.5 Medium - Show olderLoading…