nodejs10 vulnerabilities (openSUSE)
48 vulnerabilities.
-
nodejs10openSUSE Eclipse Jetty XmlParser allows arbitrary DOCTYPE declarations 7.5 High -
nodejs10openSUSE An untrusted search path vulnerability exists in Node.js. <19.6.1, <18.14.1, <16.19.1, and <14.21... 4.2 Medium -
nodejs10openSUSE http-cache-semantics vulnerable to Regular Expression Denial of Service 5.3 Medium -
nodejs10openSUSE A OS Command Injection vulnerability exists in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19... 8.1 High -
nodejs10openSUSE The llhttp parser in the http module in Node v18.7.0 does not correctly handle header fields that... 6.5 Medium -
nodejs10openSUSE The llhttp parser in the http module in Node v17.6.0 does not correctly handle multi-line... 6.5 Medium -
nodejs10openSUSE llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields 6.5 Medium -
nodejs10openSUSE llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding 6.5 Medium -
nodejs10openSUSE A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due... 8.1 High -
nodejs10openSUSE A Denial of Service vulnerability exists in qs up to 6.8.0 due to insufficient sanitization of... 7.5 High -
nodejs10openSUSE Prototype Pollution in minimist 9.8 Critical -
nodejs10openSUSE Due to the formatting logic of the "console.table()" function it was not safe to allow user... 8.2 High -
nodejs10openSUSE Exposure of Sensitive Information to an Unauthorized Actor in node-fetch/node-fetch 8.8 High -
nodejs10openSUSE The parser in accepts requests with a space (SP) right after the header name before the colon.... 6.5 Medium -
nodejs10openSUSE Prototype Pollution in kriszyp/json-schema 9.8 Critical -
nodejs10openSUSE The parse function in llhttp < 2.1.4 and < 6.0.6. ignores chunk extensions when parsing the body... 6.5 Medium -
nodejs10openSUSE Inefficient Regular Expression Complexity in chalk/ansi-regex 7.5 High -
nodejs10openSUSE Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an... 7.5 High -
nodejs10openSUSE If the Node.js https API was used incorrectly and "undefined" was in passed for the ... 5.3 Medium -
nodejs10openSUSE Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS,... 9.8 Critical -
nodejs10openSUSE A flaw was found in c-ares library, where a missing input validation check of host names returned... 5.6 Medium -
nodejs10openSUSE Use After Free in node.js 9.8 Critical -
nodejs10openSUSE Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization 8.2 High -
nodejs10openSUSE Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning 8.2 High -
nodejs10openSUSE Out-of-Bounds Read in Node.js 5.3 Medium -
nodejs10openSUSE Regular Expression Denial of Service (ReDoS) 5.3 Medium -
nodejs10openSUSE CA certificate check bypass with X509_V_FLAG_X509_STRICT 7.4 High -
nodejs10openSUSE NULL pointer deref in signature_algorithms processing 5.9 Medium -
nodejs10openSUSE Regular Expression Denial of Service (ReDoS) 5.3 Medium -
nodejs10openSUSE Regular Expression Denial of Service (ReDoS) 7.5 High -
nodejs10openSUSE Node.js bad 7.5 High -
nodejs10openSUSE Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack... 7.5 High -
nodejs10openSUSE Integer overflow in CipherUpdate 7.5 High -
nodejs10openSUSE Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in... 6.5 Medium -
nodejs10openSUSE Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 are vulnerable to a use-after-free bug... 8.1 High -
nodejs10openSUSE EDIPARTYNAME NULL pointer dereference 5.9 Medium -
nodejs10openSUSE Prototype Pollution 7.3 High -
nodejs10openSUSE The implementation of realpath in libuv < 10.22.1, < 12.18.4, and < 14.9.0 used within Node.js... 7.8 High -
nodejs10openSUSE Sensitive information exposure through logs in npm cli 4.4 Medium -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to a flood of empty frames, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to a header leak, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Some HTTP/2 implementations are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service 7.5 High -
nodejs10openSUSE Arbitrary File Overwrite in fstream 7.5 High