nodejs14 vulnerabilities (openSUSE)
58 vulnerabilities.
-
nodejs14openSUSE When the Node.js policy feature checks the integrity of a resource against a trusted manifest,... 7.5 High -
nodejs14openSUSE A privilege escalation vulnerability exists in the experimental policy mechanism in all active... 7.5 High -
nodejs14openSUSE The use of `module.constructor.createRequire()` can bypass the policy mechanism and require... 8.8 High -
nodejs14openSUSE The use of `Module._load()` can bypass the policy mechanism and require modules outside of the... 9.8 Critical -
nodejs14openSUSE Eclipse Jetty XmlParser allows arbitrary DOCTYPE declarations 7.5 High -
nodejs14openSUSE The generateKeys() API function returned from crypto.createDiffieHellman() only generates missing... 7.5 High -
nodejs14openSUSE llhttp vulnerable to HTTP request smuggling 7.5 High -
nodejs14openSUSE The use of __proto__ in process.mainModule.__proto__.require() can bypass the policy mechanism... 7.5 High -
nodejs14openSUSE An untrusted search path vulnerability exists in Node.js. <19.6.1, <18.14.1, <16.19.1, and <14.21... 4.2 Medium -
nodejs14openSUSE A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3... 7.5 High -
nodejs14openSUSE http-cache-semantics vulnerable to Regular Expression Denial of Service 5.3 Medium -
nodejs14openSUSE A OS Command Injection vulnerability exists in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19... 8.1 High -
nodejs14openSUSE The llhttp parser in the http module in Node v18.7.0 does not correctly handle header fields that... 6.5 Medium -
nodejs14openSUSE The llhttp parser in the http module in Node v17.6.0 does not correctly handle multi-line... 6.5 Medium -
nodejs14openSUSE llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields 6.5 Medium -
nodejs14openSUSE llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding 6.5 Medium -
nodejs14openSUSE A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due... 8.1 High -
nodejs14openSUSE A Denial of Service vulnerability exists in qs up to 6.8.0 due to insufficient sanitization of... 7.5 High -
nodejs14openSUSE Prototype Pollution in minimist 9.8 Critical -
nodejs14openSUSE Infinite loop in BN_mod_sqrt() reachable when parsing certificates 7.5 High -
nodejs14openSUSE Due to the formatting logic of the "console.table()" function it was not safe to allow user... 8.2 High -
nodejs14openSUSE Moderate: nodejs:14 security update 5.3 Medium -
nodejs14openSUSE Node.js < 12.22.9, < 14.18.3, < 16.13.2, and < 17.3.1 converts SANs (Subject Alternative Names)... 5.3 Medium -
nodejs14openSUSE Accepting arbitrary Subject Alternative Name (SAN) types, unless a PKI is specifically defined to... 7.4 High -
nodejs14openSUSE Exposure of Sensitive Information to an Unauthorized Actor in node-fetch/node-fetch 8.8 High -
nodejs14openSUSE The parser in accepts requests with a space (SP) right after the header name before the colon.... 6.5 Medium -
nodejs14openSUSE Prototype Pollution in kriszyp/json-schema 9.8 Critical -
nodejs14openSUSE The parse function in llhttp < 2.1.4 and < 6.0.6. ignores chunk extensions when parsing the body... 6.5 Medium -
nodejs14openSUSE Inefficient Regular Expression Complexity in chalk/ansi-regex 7.5 High -
nodejs14openSUSE Arbitrary File Creation/Overwrite on Windows via insufficient relative path sanitization 8.2 High -
nodejs14openSUSE UNIX Symbolic Link (Symlink) Following in @npmcli/arborist 8.2 High -
nodejs14openSUSE UNIX Symbolic Link (Symlink) Following in @npmcli/arborist 8.2 High -
nodejs14openSUSE Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning using symbolic links 8.2 High -
nodejs14openSUSE Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning using symbolic links 8.2 High -
nodejs14openSUSE Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an... 7.5 High -
nodejs14openSUSE If the Node.js https API was used incorrectly and "undefined" was in passed for the ... 5.3 Medium -
nodejs14openSUSE Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS,... 9.8 Critical -
nodejs14openSUSE A flaw was found in c-ares library, where a missing input validation check of host names returned... 5.6 Medium -
nodejs14openSUSE Use After Free in node.js 9.8 Critical -
nodejs14openSUSE Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization 8.2 High -
nodejs14openSUSE Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning 8.2 High -
nodejs14openSUSE Out-of-Bounds Read in Node.js 5.3 Medium -
nodejs14openSUSE Regular Expression Denial of Service (ReDoS) 5.3 Medium -
nodejs14openSUSE Regular Expression Denial of Service (ReDoS) 5.3 Medium -
nodejs14openSUSE Regular Expression Denial of Service (ReDoS) 7.5 High -
nodejs14openSUSE Node.js bad 7.5 High -
nodejs14openSUSE Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack... 7.5 High -
nodejs14openSUSE Heap buffer overflow in V8 in Google Chrome prior to 88.0.4324.150 allowed a remote attacker to... 8.8 High -
nodejs14openSUSE Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in... 6.5 Medium -
nodejs14openSUSE Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 are vulnerable to a use-after-free bug... 8.1 High - Show olderLoading…