postgresql10 vulnerabilities (openSUSE)
24 vulnerabilities.
-
postgresql10openSUSE A vulnerability found in postgresql. On this security issue an attack requires permission to... 8.0 High -
postgresql10openSUSE A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when... 8.8 High -
postgresql10openSUSE A man-in-the-middle attacker can inject false responses to the client's first few queries,... 5.9 Medium -
postgresql10openSUSE When the server is configured to use trust authentication with a clientcert requirement or to use... 8.1 High -
postgresql10openSUSE A flaw was found in postgresql. Using an INSERT ... ON CONFLICT ... DO UPDATE command on a... 6.5 Medium -
postgresql10openSUSE A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17... 8.8 High -
postgresql10openSUSE Incorrect Comparison, Permissive List of Allowed Inputs, and Privilege Context Switching Error in PostgreSQL 7.5 High -
postgresql10openSUSE SQL Injection 8.8 High -
postgresql10openSUSE Use of a Broken or Risky Cryptographic Algorithm in PostgreSQL 8.1 High -
postgresql10openSUSE Untrusted Search Path in PostgreSQL 7.3 High -
postgresql10openSUSE It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly... 7.1 High -
postgresql10openSUSE A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub... 3.1 Low -
postgresql10openSUSE A flaw was discovered in postgresql where arbitrary SQL statements can be executed given a... 7.5 High -
postgresql10openSUSE PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack... 7.5 High -
postgresql10openSUSE A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding... 3.1 Low -
postgresql10openSUSE postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and... 8.0 High -
postgresql10openSUSE It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed... 7.1 High -
postgresql10openSUSE A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to... 8.5 High -
postgresql10openSUSE postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog... 4.2 Medium -
postgresql10openSUSE A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other... 8.8 High -
postgresql10openSUSE Memory disclosure vulnerability in table partitioning was found in postgresql 10.x before 10.2,... 6.5 Medium -
postgresql10openSUSE In postgresql 9.3.x before 9.3.21, 9.4.x before 9.4.16, 9.5.x before 9.5.11, 9.6.x before 9.6.7... 7.0 High -
postgresql10openSUSE INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, and... 6.5 Medium -
postgresql10openSUSE Invalid json_populate_recordset or jsonb_populate_recordset function calls in PostgreSQL 10.x... 8.1 High