postgresql12 vulnerabilities (openSUSE)
33 vulnerabilities.
-
postgresql12openSUSE PostgreSQL PL/Perl environment variable changes execute arbitrary code 8.8 High -
postgresql12openSUSE PostgreSQL SET ROLE, SET SESSION AUTHORIZATION reset to wrong user ID 4.2 Medium -
postgresql12openSUSE PostgreSQL libpq retains an error message from man-in-the-middle 3.1 Low -
postgresql12openSUSE PostgreSQL row security below e.g. subqueries disregards user ID changes 4.2 Medium -
postgresql12openSUSE PostgreSQL relation replacement during pg_dump executes arbitrary SQL 8.8 High -
postgresql12openSUSE PostgreSQL non-owner REFRESH MATERIALIZED VIEW CONCURRENTLY executes arbitrary SQL 8.0 High -
postgresql12openSUSE Postgresql: role pg_signal_backend can signal certain superuser processes. 2.2 Low -
postgresql12openSUSE Postgresql: buffer overrun from integer overflow in array modification 8.8 High -
postgresql12openSUSE Postgresql: memory disclosure in aggregate function calls 4.3 Medium -
postgresql12openSUSE Postgresql: extension script @substitutions@ within quoting allow sql injection 7.5 High -
postgresql12openSUSE Row security policies disregard user ID changes after inlining; PostgreSQL could permit incorrect... 5.4 Medium -
postgresql12openSUSE schema_element defeats protective search_path changes; It was found that certain database calls... 7.2 High -
postgresql12openSUSE In PostgreSQL, a modified, unauthenticated server can send an unterminated string during the... 3.7 Low -
postgresql12openSUSE A vulnerability found in postgresql. On this security issue an attack requires permission to... 8.0 High -
postgresql12openSUSE A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when... 8.8 High -
postgresql12openSUSE A man-in-the-middle attacker can inject false responses to the client's first few queries,... 5.9 Medium -
postgresql12openSUSE When the server is configured to use trust authentication with a clientcert requirement or to use... 8.1 High -
postgresql12openSUSE A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory... 6.5 Medium -
postgresql12openSUSE A flaw was found in postgresql. Using an UPDATE ... RETURNING command on a purpose-crafted table,... 6.5 Medium -
postgresql12openSUSE A flaw was found in postgresql. Using an INSERT ... ON CONFLICT ... DO UPDATE command on a... 6.5 Medium -
postgresql12openSUSE A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17... 8.8 High -
postgresql12openSUSE Generation of Error Message Containing Sensitive Information in postgresql 4.3 Medium -
postgresql12openSUSE Incorrect Comparison, Permissive List of Allowed Inputs, and Privilege Context Switching Error in PostgreSQL 7.5 High -
postgresql12openSUSE SQL Injection 8.8 High -
postgresql12openSUSE Use of a Broken or Risky Cryptographic Algorithm in PostgreSQL 8.1 High -
postgresql12openSUSE Untrusted Search Path in PostgreSQL 7.3 High -
postgresql12openSUSE It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly... 7.1 High -
postgresql12openSUSE A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub... 3.1 Low -
postgresql12openSUSE A flaw was discovered in postgresql where arbitrary SQL statements can be executed given a... 7.5 High -
postgresql12openSUSE A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding... 3.1 Low -
postgresql12openSUSE It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed... 7.1 High -
postgresql12openSUSE A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to... 8.5 High -
postgresql12openSUSE postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog... 4.2 Medium