unbound vulnerabilities (openSUSE)
79 vulnerabilities.
unboundopenSUSECache poisoning via the ECS-enabled Rebirthday Attack8.7 HighunboundopenSUSEUnbounded name compression could lead to Denial of Service5.3 MediumunboundopenSUSEUnbound: null pointer dereference in unbound2.8 LowunboundopenSUSEThe DNS protocol in RFC 1035 and updates allows remote attackers to cause a denial of service ...7.5 HighunboundopenSUSEDenial of service when trimming EDE text on positive replies7.5 HighunboundopenSUSEThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 HighunboundopenSUSECertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 HighunboundopenSUSENRDelegation Attack7.5 HighunboundopenSUSENovel "ghost domain names" attack by updating almost expired delegation information6.5 MediumunboundopenSUSENovel "ghost domain names" attack by introducing subdomain delegations6.5 MediumunboundopenSUSEUnbound before 1.9.5 allows configuration injection in create_unbound_ad_servers.sh upon a...5.9 MediumunboundopenSUSEUnbound before 1.9.5 allows an integer overflow in the regional allocator via regional_alloc.9.8 CriticalunboundopenSUSEUnbound before 1.9.5 allows an integer overflow in the regional allocator via the ALIGN_UP macro.9.8 CriticalunboundopenSUSEUnbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an...9.8 CriticalunboundopenSUSEUnbound before 1.9.5 allows an out-of-bounds write in sldns_bget_token_par.9.8 CriticalunboundopenSUSEUnbound before 1.9.5 allows an assertion failure and denial of service in synth_cname.7.5 HighunboundopenSUSEUnbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an...7.5 HighunboundopenSUSEUnbound before 1.9.5 allows an integer overflow in a size calculation in dnscrypt/dnscrypt.c.9.8 CriticalunboundopenSUSEUnbound before 1.9.5 allows an integer overflow in a size calculation in respip/respip.c.9.8 CriticalunboundopenSUSEUnbound before 1.9.5 allows an infinite loop via a compressed name in dname_pkt_copy.7.5 HighunboundopenSUSEUnbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy.7.5 HighunboundopenSUSEUnbound before 1.9.5 allows an out-of-bounds write via a compressed name in rdata_copy.9.8 CriticalunboundopenSUSELocal symlink attack in Unbound and NSD5.5 MediumunboundopenSUSEUnbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers.7.5 HighunboundopenSUSEUnbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an "NXNSAttack"...7.5 HighunboundopenSUSEUnbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code...7.3 HighunboundopenSUSEUnbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a...7.5 HighunboundopenSUSEA flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An...5.3 MediumunboundopenSUSEiterator.c in NLnet Labs Unbound before 1.5.1 does not limit delegation chaining, which allows...4.3 Medium