CVE-2020-0458
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a...
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-9 Android-10 Android-8.0 Android-8.1Android ID: A-160265164
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-9 Android-10 Android-8.0 Android-8.1Android ID: A-160265164
- Record
CVE-2020-0458- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-190, CWE-787
- Updated
- 2026-11-02
CVE List No score
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-9 Android-10 Android-8.0 Android-8.1Android ID: A-160265164
- Record
CVE-2020-0458- Updated
- 2026-11-02
EUVDEUVD-2020-1959 No score
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-9 Android-10 Android-8.0 Android-8.1Android ID: A-160265164
- Record
EUVD-2020-1959- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-95vg-hp9r-6q5x No score
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a...
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-9 Android-10 Android-8.0 Android-8.1Android ID: A-160265164
- Record
GHSA-95vg-hp9r-6q5x- Weakness
- CWE-190
- Updated
- 2026-11-02
OSVASB-A-160265164 No score
In SPDIFEncoder::writeBurstBufferBytes and related methods of SPDIFEncoder.cpp, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation.
- Record
ASB-A-160265164- Updated
- 2026-11-05
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
platform/system/mediaAndroid |
8.0:0 up to 8.0:2020-12-01, plus listed versions 8.0 |
8.0:2020-12-01 |
platform/system/mediaAndroid |
8.1:0 up to 8.1:2020-12-01, plus listed versions 8.1 |
8.1:2020-12-01 |
platform/system/mediaAndroid |
9:0 up to 9:2020-12-01, plus listed versions 9 |
9:2020-12-01 |
platform/system/mediaAndroid |
10:0 up to 10:2020-12-01, plus listed versions 10 |
10:2020-12-01 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | nanopathi/system_media_AOSP10_r33_CVE-2020-0458 | 2022-04-21 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-0458 is a high vulnerability (CVSS 7.8) in Google Android, published December 1, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in platform/system/media 8.0:2020-12-01.
References
source.android.com/security/bulletin/2020-12-01
nvd.nist.gov/vuln/detail/CVE-2020-0458
github.com/advisories/GHSA-95vg-hp9r-6q5x
android.googlesource.com/platform/system/media/+/4523a5863f7d8f449600e85e946cfdc9cff408b2
android.googlesource.com/platform/system/media/+/1f73a728ef4b6d7d350c0715bdb10d59e5b5f9be