Every CVE Search/ Get API key

CVE-2016-10190

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1...

9.8 CriticalPublic exploitFix available

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

8.36%Up 5.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
CVE-2016-10190
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
CVE-2016-10190
Updated
2026-11-02
EUVDEUVD-2016-1377 No score

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
EUVD-2016-1377
Updated
2026-11-03
GitHub AdvisoriesGHSA-2x24-gfqp-9jhx 9.8

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1...

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
GHSA-2x24-gfqp-9jhx
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2016-10190 9.8

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
ALPINE-CVE-2016-10190
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
CVE-2016-10190
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2016-10190 9.8

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
DEBIAN-CVE-2016-10190
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10190 9.8

Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.

Record
UBUNTU-CVE-2016-10190
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2017:0958-1 No score

Security update for ffmpeg

This update for ffmpeg fixes the following issues:

Security issue fixed:

  • CVE-2016-10190: remote code execution vulnerability [ 1 - libavformat/http.c ] (boo#1022920)

Detailed ChangeLog:

Record
openSUSE-SU-2017:0958-1
Updated
2026-11-02
OSVopenSUSE-SU-2017:0961-1 No score

Security update for ffmpeg

This update for ffmpeg fixes the following issues:

Security issue fixed:

  • CVE-2016-10190: remote code execution vulnerability [ 1 - libavformat/http.c ] (boo#1022920)

Detailed ChangeLog:

Record
openSUSE-SU-2017:0961-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10754-1 No score

ffmpeg-4-4.4-5.2 on GA media

These are all security issues fixed in the ffmpeg-4-4.4-5.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10754-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.3
before 2.8.11-r0
2.8.11-r0
ffmpeg
Alpine:v3.4
before 3.0.7-r0
3.0.7-r0
ffmpeg
Debian:12
before 7:3.2.2-1
7:3.2.2-1
ffmpeg
Debian:13
before 7:3.2.2-1
7:3.2.2-1
ffmpeg
Debian:14
before 7:3.2.2-1
7:3.2.2-1
libav
Debian:8
before 6:11.12-1~deb8u2, plus listed versions
6:11.11-1~deb8u16:11.12-1~deb8u16:11.3-16:11.3-1+deb8u16:11.3-2
Show 9 moreShow less
6:11.3-36:11.4-16:11.4-1~deb8u16:11.4-26:11.4-2+x32.16:11.6-1~deb8u16:11.7-1~deb8u16:11.8-1~deb8u16:11.9-1~deb8u1
6:11.12-1~deb8u2
libav
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
6:0.8.7-1ubuntu26:9.10-1ubuntu16:9.10-1ubuntu26:9.10-1ubuntu56:9.10-1ubuntu6
Show 9 moreShow less
6:9.10-1ubuntu76:9.11-2ubuntu16:9.11-2ubuntu26:9.13-0ubuntu0.14.04.16:9.14-0ubuntu0.14.04.16:9.16-0ubuntu0.14.04.16:9.18-0ubuntu0.14.04.16:9.20-0ubuntu0.14.04.16:9.20-0ubuntu0.14.04.1+esm1
None known
ffmpeg
Ubuntu:16.04:LTS
before 7:2.8.11-0ubuntu0.16.04.1, plus listed versions
7:2.7.2-1build17:2.8.1-1ubuntu17:2.8.2-1ubuntu17:2.8.3-17:2.8.4-1
Show 8 moreShow less
7:2.8.4-1ubuntu17:2.8.4-1ubuntu27:2.8.4-1ubuntu37:2.8.4-1ubuntu47:2.8.6-1ubuntu17:2.8.6-1ubuntu27:2.8.8-0ubuntu0.16.04.17:2.8.10-0ubuntu0.16.04.1
7:2.8.11-0ubuntu0.16.04.1
ffmpeg
SUSE:Package Hub 12 SP1
before 3.1.6-5.1
3.1.6-5.1
ffmpeg
SUSE:Package Hub 12 SP2
before 3.1.6-5.1
3.1.6-5.1
ffmpeg-4
openSUSE:Tumbleweed
before 4.4-5.2
4.4-5.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubmuzalam/FFMPEG-exploit2022-05-07

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10190 is a critical vulnerability (CVSS 9.8) in Ffmpeg, published February 9, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.36%, the 94th percentile. Fixed in ffmpeg 2.8.11-r0.

References

Show 54 moreShow less
MoveEnter Open