Every CVE Search/ Get API key

CVE-2017-10919

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a...

6.5 MediumFix available

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.90%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
CVE-2017-10919
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
CVE-2017-10919
Updated
2026-11-02
EUVDEUVD-2017-2557 No score

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
EUVD-2017-2557
Updated
2026-11-03
GitHub AdvisoriesGHSA-rj6j-c835-5x5f 6.5

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a...

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
GHSA-rj6j-c835-5x5f
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVALPINE-CVE-2017-10919 6.5

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
ALPINE-CVE-2017-10919
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.5

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
CVE-2017-10919
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-10919 6.5

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
DEBIAN-CVE-2017-10919
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-10919 6.5

Xen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.

Record
UBUNTU-CVE-2017-10919
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xen
Alpine:v3.10
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.11
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.12
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.13
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.14
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.15
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.16
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.17
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.18
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.19
before 4.9.0-r0
4.9.0-r0
Show 16 moreShow less
Affected packages
PackageAffectedFixed
xen
Alpine:v3.20
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.21
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.22
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.23
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.24
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.3
before 4.6.6-r0
4.6.6-r0
xen
Alpine:v3.4
before 4.6.6-r0
4.6.6-r0
xen
Alpine:v3.5
before 4.7.3-r0
4.7.3-r0
xen
Alpine:v3.6
before 4.8.2-r0
4.8.2-r0
xen
Alpine:v3.7
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.8
before 4.9.0-r0
4.9.0-r0
xen
Alpine:v3.9
before 4.9.0-r0
4.9.0-r0
xen
Debian:12
before 4.8.1-1+deb9u3
4.8.1-1+deb9u3
xen
Debian:13
before 4.8.1-1+deb9u3
4.8.1-1+deb9u3
xen
Debian:14
before 4.8.1-1+deb9u3
4.8.1-1+deb9u3
xen
Ubuntu:16.04:LTS
before 4.6.5-0ubuntu1.2, plus listed versions
4.5.1-0ubuntu14.5.1-0ubuntu24.6.0-1ubuntu14.6.0-1ubuntu24.6.0-1ubuntu4
Show 5 moreShow less
4.6.0-1ubuntu4.14.6.0-1ubuntu4.24.6.0-1ubuntu4.34.6.5-0ubuntu14.6.5-0ubuntu1.1
4.6.5-0ubuntu1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-10919 is a medium vulnerability (CVSS 6.5) in Xen, published July 5, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in xen 4.9.0-r0.

References

Show 5 moreShow less
MoveEnter Open