CVE-2018-14447
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
CVE-2018-14447- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
CVE-2018-14447- Updated
- 2026-11-02
EUVDEUVD-2018-6364 No score
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
EUVD-2018-6364- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3fcp-jc98-wc37
8.8
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
GHSA-3fcp-jc98-wc37- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-14447
8.8
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
ALPINE-CVE-2018-14447- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
CVE-2018-14447- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-14447
8.8
trim_whitespace in lexer.l in libConfuse v3.2.1 has an out-of-bounds read.
- Record
UBUNTU-CVE-2018-14447- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10930-1 No score
libconfuse-devel-3.3-1.7 on GA media
These are all security issues fixed in the libconfuse-devel-3.3-1.7 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10930-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
confuseAlpine:v3.10 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.11 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.12 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.13 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.14 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.15 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.16 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.17 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.18 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.19 |
before 3.2.2-r0 | 3.2.2-r0 |
Show 10 moreShow less
| Package | Affected | Fixed |
|---|---|---|
confuseAlpine:v3.20 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.21 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.22 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.23 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.24 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseAlpine:v3.9 |
before 3.2.2-r0 | 3.2.2-r0 |
confuseDebian:8 |
before 2.7-5+deb8u1, plus listed versions 2.7-5 |
2.7-5+deb8u1 |
confuseUbuntu:14.04:LTS |
before 2.7-5+deb8u1build0.14.04.1, plus listed versions 2.7-42.7-4ubuntu1 |
2.7-5+deb8u1build0.14.04.1 |
confuseUbuntu:16.04:LTS |
before 2.7-5+deb8u1build0.16.04.1, plus listed versions 2.7-5 |
2.7-5+deb8u1build0.16.04.1 |
confuseUbuntu:18.04:LTS |
before 3.2.1+dfsg-4ubuntu0.1, plus listed versions 3.2+really3.0+dfsg-13.2.1+dfsg-33.2.1+dfsg-4 |
3.2.1+dfsg-4ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-14447 is a high vulnerability (CVSS 8.8) in Libconfuse Project Libconfuse, published July 20, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in confuse 3.2.2-r0.
References
hac425.unaux.com/index.php/archives/64
lists.debian.org/debian-lts-announce/2018/08/msg00017.html
github.com/martinh/libconfuse/issues/109
nvd.nist.gov/vuln/detail/CVE-2018-14447
github.com/advisories/GHSA-3fcp-jc98-wc37
security.alpinelinux.org/vuln/CVE-2018-14447
ubuntu.com/security/CVE-2018-14447
cve.org/CVERecord?id=CVE-2018-14447
suse.com/security/cve/CVE-2018-14447