CVE-2018-15120
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote...
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
CVE-2018-15120- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
CVE-2018-15120- Updated
- 2026-11-02
EUVDEUVD-2018-7002 No score
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
EUVD-2018-7002- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6gmw-hfp8-7f52
6.5
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote...
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
GHSA-6gmw-hfp8-7f52- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-15120
6.5
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
ALPINE-CVE-2018-15120- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
6.5
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
CVE-2018-15120- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2018-15120
6.5
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
DEBIAN-CVE-2018-15120- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-15120
6.5
libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
- Record
UBUNTU-CVE-2018-15120- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10843-1 No score
hexchat-2.14.3-4.4 on GA media
These are all security issues fixed in the hexchat-2.14.3-4.4 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10843-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11148-1 No score
libpango-1_0-0-1.48.10-1.3 on GA media
These are all security issues fixed in the libpango-1_0-0-1.48.10-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11148-1- Updated
- 2026-11-02
OSVSUSE-SU-2018:2763-1 No score
Security update for pango
This update for pango fixes the following issues:
Security issue fixed:
- CVE-2018-15120: Fixed a denial of service when parsing emoji (bsc#1103877)
- Record
SUSE-SU-2018:2763-1- Updated
- 2026-11-02
OSVUSN-3750-1 No score
pango1.0 vulnerability
Jeffrey M. discovered that Pango incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service.
- Record
USN-3750-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pangoAlpine:v3.7 |
1.40.8 up to 1.40.14-r1 | 1.40.14-r1 |
pangoAlpine:v3.8 |
1.40.8 up to 1.40.14-r1 | 1.40.14-r1 |
pango1.0Debian:12 |
before 1.42.4-1 | 1.42.4-1 |
pango1.0Debian:13 |
before 1.42.4-1 | 1.42.4-1 |
pango1.0Debian:14 |
before 1.42.4-1 | 1.42.4-1 |
pangoSUSE:Linux Enterprise Module for Basesystem 15 |
before 1.40.14-3.3.1 | 1.40.14-3.3.1 |
pangoSUSE:Linux Enterprise Module for Desktop Applications 15 |
before 1.40.14-3.3.1 | 1.40.14-3.3.1 |
pango1.0Ubuntu:18.04:LTS |
before 1.40.14-1ubuntu0.1, plus listed versions 1.40.12-11.40.13-21.40.14-1 |
1.40.14-1ubuntu0.1 |
hexchatopenSUSE:Tumbleweed |
before 2.14.3-4.4 | 2.14.3-4.4 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Libpango 1.40.8 - Denial of Service (PoC) | 2018-08-27 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-15120 is a medium vulnerability (CVSS 6.5) in Gnome Pango, published August 22, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.4%, the 96th percentile. Fixed in pango 1.40.14-r1.
References
exploit-db.com/exploits/45263
github.com/GNOME/pango/blob/1.42.4/NEWS
usn.ubuntu.com/3750-1
github.com/GNOME/pango/commit/71aaeaf020340412b8d012fe23a556c0420eda5f
security.gentoo.org/glsa/201811-07
mail.gnome.org/archives/distributor-list/2018-August/msg00001.html
Show 14 moreShow less
52.117.224.77/xfce4-pdos.webm
ign.com/articles/2018/10/16/ps4s-are-reportedly-being-bricked-and-sony-is-working-on-a-fix
reddit.com/r/PS4/comments/9o5efg/message_bricking_console_megathread
i.redd.it/v7p4n2ptu0s11.jpg
nvd.nist.gov/vuln/detail/CVE-2018-15120
github.com/advisories/GHSA-6gmw-hfp8-7f52
security.alpinelinux.org/vuln/CVE-2018-15120
security-tracker.debian.org/tracker/CVE-2018-15120
suse.com/support/update/announcement/2018/suse-su-20182763-1
bugzilla.suse.com/1103877
suse.com/security/cve/CVE-2018-15120
ubuntu.com/security/CVE-2018-15120
ubuntu.com/security/notices/USN-3750-1
cve.org/CVERecord?id=CVE-2018-15120