CVE-2018-19608
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker...
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.7
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
CVE-2018-19608- CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 1.9 Low
AV:L/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
CVE List No score
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
CVE-2018-19608- Updated
- 2026-11-02
EUVDEUVD-2018-11296 No score
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
EUVD-2018-11296- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vqf5-9m3g-rhvm
4.7
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker...
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
GHSA-vqf5-9m3g-rhvm- CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-19608
4.7
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
ALPINE-CVE-2018-19608- CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
OSV
4.7
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
CVE-2018-19608- CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2018-19608
4.7
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
DEBIAN-CVE-2018-19608- CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-19608
4.7
Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
- Record
UBUNTU-CVE-2018-19608- CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVMGASA-2019-0027 No score
Updated mbedtls packages fix security vulnerability
A vulnerability was found in mbedTLS which allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites (CVE-2018-19608).
- Record
MGASA-2019-0027- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11043-1 No score
libmbedcrypto7-2.27.0-1.2 on GA media
These are all security issues fixed in the libmbedcrypto7-2.27.0-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11043-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:11119-1 No score
libeverest-3.6.6-1.1 on GA media
These are all security issues fixed in the libeverest-3.6.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:11119-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mbedtlsAlpine:v3.10 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.11 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.12 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.13 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.14 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.15 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.16 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.17 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.18 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.19 |
before 2.14.1-r0 | 2.14.1-r0 |
Show 20 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mbedtlsAlpine:v3.20 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.21 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.22 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.23 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.24 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsAlpine:v3.9 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtls2Alpine:v3.20 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtls2Alpine:v3.21 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtls2Alpine:v3.22 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtls2Alpine:v3.23 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtls2Alpine:v3.24 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtls3Alpine:v3.24 |
before 2.14.1-r0 | 2.14.1-r0 |
mbedtlsDebian:12 |
before 2.14.1-1 | 2.14.1-1 |
mbedtlsDebian:13 |
before 2.14.1-1 | 2.14.1-1 |
mbedtlsDebian:14 |
before 2.14.1-1 | 2.14.1-1 |
mbedtlsMageia:6 |
before 2.7.8-1.mga6 | 2.7.8-1.mga6 |
mbedtlsUbuntu:16.04:LTS |
All versions, plus listed versions 2.1.2-12.2.0-12.2.1-12.2.1-22.2.1-2ubuntu0.12.2.1-2ubuntu0.22.2.1-2ubuntu0.3 |
None known |
mbedtlsUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 2.5.1-1ubuntu12.6.0-12.7.0-22.8.0-12.8.0-1ubuntu0.1~esm1 |
None known |
mbedtls-2openSUSE:Tumbleweed From an advisory covering 5 CVEs |
before 2.27.0-1.2 | 2.27.0-1.2 |
mbedtls-3openSUSE:Tumbleweed From an advisory covering 14 CVEs |
before 3.6.6-1.1 | 3.6.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-19608 is a medium vulnerability (CVSS 4.7) in Arm Mbed Tls, published December 5, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in mbedtls 2.14.1-r0.
References
tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-03
cat.eyalro.net
tls.mbed.org/tech-updates/releases/mbedtls-2.14.1-2.7.8-and-2.1.17-released
nvd.nist.gov/vuln/detail/CVE-2018-19608
github.com/advisories/GHSA-vqf5-9m3g-rhvm
security.alpinelinux.org/vuln/CVE-2018-19608
Show 21 moreShow less
security-tracker.debian.org/tracker/CVE-2018-19608
advisories.mageia.org/MGASA-2019-0027.html
bugs.mageia.org/show_bug.cgi?id=24064
tls.mbed.org/tech-updates/releases/mbedtls-2.14.0-2.7.7-and-2.1.16-released
lists.fedoraproject.org/archives/list/[email protected]/thread/JPMHKBJDZVFFML2CJYXG3ELX7ADDG6ET
ubuntu.com/security/CVE-2018-19608
cve.org/CVERecord?id=CVE-2018-19608
suse.com/security/cve/CVE-2017-14032
suse.com/security/cve/CVE-2017-2784
suse.com/security/cve/CVE-2018-0487
suse.com/security/cve/CVE-2018-0488
suse.com/security/cve/CVE-2018-19608
suse.com/security/cve/CVE-2014-8627
suse.com/security/cve/CVE-2014-8628
suse.com/security/cve/CVE-2015-1182
suse.com/security/cve/CVE-2015-5291
suse.com/security/cve/CVE-2015-7575
suse.com/security/cve/CVE-2021-24119
suse.com/security/cve/CVE-2021-45450
suse.com/security/cve/CVE-2022-35409
suse.com/security/cve/CVE-2022-46393