Every CVE Search/ Get API key

CVE-2019-17068

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a...

7.5 HighFix available

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.81%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
CVE-2019-17068
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-74
Updated
2026-11-02
CVE List No score

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
CVE-2019-17068
Updated
2026-11-02
EUVDEUVD-2019-7539 No score

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
EUVD-2019-7539
Updated
2026-11-03
GitHub AdvisoriesGHSA-4r38-38gx-5vr9 No score

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a...

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
GHSA-4r38-38gx-5vr9
Updated
2026-11-02
OSVALPINE-CVE-2019-17068 7.5

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
ALPINE-CVE-2019-17068
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-03
OSV 7.5

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
CVE-2019-17068
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 7 moreShow less
OSVDEBIAN-CVE-2019-17068 7.5

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
DEBIAN-CVE-2019-17068
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-17068 7.5

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

Record
UBUNTU-CVE-2019-17068
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2020-0003 No score

Updated putty packages fix security vulnerabilities

Updated putty package fixes security vulnerabilities:

Two separate vulnerabilities affecting the obsolete SSH-1 protocol, both available before host key checking.

Vulnerability in all the SSH client tools (PuTTY, Plink, PSFTP, and PSCP) if a malicious program can impersonate Pageant.

Crash in GSSAPI / Kerberos key exchange triggered if the server provided an ordinary SSH host key as part of the exchange.

Insufficient handling of terminal escape sequences, that should delimit the pasted data in bracketed paste mode (CVE-2019-17068).

Possible information leak caused by SSH-1 disconnection messages (CVE-2019-17069).

The putty package has been updated to version 0.73, fixing theese issues and other bugs.

Record
MGASA-2020-0003
Updated
2026-11-02
OSVopenSUSE-SU-2019:2276-1 No score

Security update for putty

This update for putty to version 0.73 fixes the following issues:

Security issues fixed:

  • CVE-2019-17068: Fixed the insufficient handling of terminal escape sequences, that should delimit the pasted data in bracketed paste mode (boo#1152753).
  • CVE-2019-17069: Fixed a possible information leak caused by SSH-1 disconnection messages (boo#1152753).
Record
openSUSE-SU-2019:2276-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:2277-1 No score

Security update for putty

This update for putty to version 0.73 fixes the following issues:

  • CVE-2019-17068: Fixed the insufficient handling of terminal escape sequences, that should delimit the pasted data in bracketed paste mode (boo#1152753).
  • CVE-2019-17069: Fixed a possible information leak caused by SSH-1 disconnection messages (boo#1152753).
Record
openSUSE-SU-2019:2277-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:2292-1 No score

Security update for putty

This update for putty to version 0.73 fixes the following issues:

Security issues fixed:

  • CVE-2019-17068: Fixed the insufficient handling of terminal escape sequences, that should delimit the pasted data in bracketed paste mode (boo#1152753).
  • CVE-2019-17069: Fixed a possible information leak caused by SSH-1 disconnection messages (boo#1152753).

This update was imported from the openSUSE:Leap:15.0:Update update project.

Record
openSUSE-SU-2019:2292-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11201-1 No score

putty-0.76-1.2 on GA media

These are all security issues fixed in the putty-0.76-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11201-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
putty
Alpine:v3.10
before 0.73-r0
0.73-r0
putty
Alpine:v3.11
before 0.73-r0
0.73-r0
putty
Alpine:v3.12
before 0.73-r0
0.73-r0
putty
Alpine:v3.13
before 0.73-r0
0.73-r0
putty
Alpine:v3.14
before 0.73-r0
0.73-r0
putty
Alpine:v3.15
before 0.73-r0
0.73-r0
putty
Alpine:v3.16
before 0.73-r0
0.73-r0
putty
Alpine:v3.17
before 0.73-r0
0.73-r0
putty
Alpine:v3.18
before 0.73-r0
0.73-r0
putty
Alpine:v3.19
before 0.73-r0
0.73-r0
Show 18 moreShow less
Affected packages
PackageAffectedFixed
putty
Alpine:v3.20
before 0.73-r0
0.73-r0
putty
Alpine:v3.21
before 0.73-r0
0.73-r0
putty
Alpine:v3.22
before 0.73-r0
0.73-r0
putty
Alpine:v3.23
before 0.73-r0
0.73-r0
putty
Alpine:v3.24
before 0.73-r0
0.73-r0
putty
Alpine:v3.8
before 0.73-r0
0.73-r0
putty
Alpine:v3.9
before 0.73-r0
0.73-r0
putty
Debian:12
before 0.73-1
0.73-1
putty
Debian:13
before 0.73-1
0.73-1
putty
Debian:14
before 0.73-1
0.73-1
putty
Mageia:7
From an advisory covering 2 CVEs
before 0.73-1.mga7
0.73-1.mga7
putty
Ubuntu:16.04:LTS
All versions, plus listed versions
0.65-20.66-10.66-20.66-30.66-4
Show 4 moreShow less
0.67-10.67-20.67-3build0.16.04.10.67-3+deb9u1build0.16.04.1
None known
putty
Ubuntu:18.04:LTS
All versions, plus listed versions
0.70-10.70-20.70-30.70-4
None known
putty
openSUSE:Leap 15.0
From an advisory covering 2 CVEs
before 0.73-lp150.18.1
0.73-lp150.18.1
putty
openSUSE:Leap 15.1
From an advisory covering 2 CVEs
before 0.73-lp151.3.6.1
0.73-lp151.3.6.1
putty
SUSE:Package Hub 15
From an advisory covering 2 CVEs
before 0.73-bp151.4.6.1
0.73-bp151.4.6.1
putty
SUSE:Package Hub 15 SP1
From an advisory covering 2 CVEs
before 0.73-bp151.4.6.1
0.73-bp151.4.6.1
putty
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 0.76-1.2
0.76-1.2

History

History
RecordedChangedSources
affected, facts
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-17068 is a high vulnerability (CVSS 7.5) in Putty, published October 1, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.81%, the 78th percentile. Fixed in putty 0.73-r0.

References

Show 17 moreShow less
MoveEnter Open